2

Is there a way to connect to a secure geoserver with OpenGeo Explorer plugin in QGIS? When I connect to geosever with a secure protocol I get the error Warning: Cannot connect using the provided certificate/key values and the site does not load in the catalog list and when I try to connect via the ip or hostname on my vpn with x.x.x.x/geoserver or hostname/geoserver it connects and I see it in the catalog but I get an error in QGIS.

Traceback (most recent call last):
  File "C:/Users/xxx/.qgis2/python/plugins\geoserverexplorer\gui\explorer.py", line 101, in run
    command(*params)
  File "C:/Users/xxx/.qgis2/python/plugins\geoserverexplorer\gui\gsexploreritems.py", line 345, in populate
    layerItem.populate()
  File "C:/Users/xxx/.qgis2/python/plugins\geoserverexplorer\gui\gsexploreritems.py", line 714, in populate
    if layer.default_style is not None:
  File "C:\Users\xxx\.qgis2\python\plugins\geoserverexplorer\ext-libs\gsconfig-1.0.6-py2.7.egg\geoserver\layer.py", line 127, in _get_default_style
    return self._resolve_style(element) if element is not None else None
  File "C:\Users\xxx\.qgis2\python\plugins\geoserverexplorer\ext-libs\gsconfig-1.0.6-py2.7.egg\geoserver\layer.py", line 135, in _resolve_style
    return self.catalog.get_style_by_url(style_workspace_url)
  File "C:\Users\xxx\.qgis2\python\plugins\geoserverexplorer\ext-libs\gsconfig-1.0.6-py2.7.egg\geoserver\catalog.py", line 797, in get_style_by_url
    dom = self.get_xml(style_workspace_url)
  File "C:\Users\xxx\.qgis2\python\plugins\geoserverexplorer\ext-libs\gsconfig-1.0.6-py2.7.egg\geoserver\catalog.py", line 211, in get_xml
    response, content = self.http.request(rest_url)
  File "C:/Users/xxx/.qgis2/python/plugins\geoserverexplorer\geoserver\retry.py", line 19, in decorator
    raise e
SSLError: [Errno 185090050] _ssl.c:340: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib

How do I get QGIS and the plugin to accept a cert?

  • For those using old versions, like me...: GeoServer 2.6.2 on plain HTTP works with QGIS 2.12.2.1 32 bits. The 64 bits version threw the above error to me. Earlier I got the same error with more recent 64 bits versions of QGIS, but I have not tried the 32 bit versions of those more recent QGIS versions. – Arjan Oct 13 '16 at 11:55
  • Update on my earlier comment: in QGIS 2.12.2.1, 32 bits, GeoServer Explorer 0.1.1 nicely lists all layers of a GeoServer 2.6.2 server, but dragging them onto a QGIS project throws "Layer is not valid". However, selecting a layer using a server connection as defined in Menu Layer, Add Layer, WFS Layer works just fine. And meanwhile I also tried QGIS 2.16.3, 32 bits. But for that, GeoServer Explorer 0.5, using a HTTP URL, throws me [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed. In short: time to upgrade our GeoServer and tooling :-) – Arjan Oct 17 '16 at 6:55
2

You don;t need to give QGIS the cert. In the Catalog Definition click the tab Configurations then Add I did basic auth with a username and password and entered a secure protocol url in the resource and it worked

Its not greatly documented but there is a refrence to secure servers in the user docs https://github.com/boundlessgeo/qgis-geoserver-plugin/blob/master/docs/source/intro.rst

enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.