6

From a WFS (with EPSG: 6247 displayed in the window) I added several layers and changed the CRS to EPSG: 3116 (the same I'm working on my current project). The layers are not overlapping even if "on the fly transformation" is enabled. Assuming that is a projection problem I made a reprojection (save as ....) and change the coordinate system but the situation remains the same.

I tried different CRS on all layers but the situation does not change. Even I downloaded the .prj again and replaced it in some layers without success.

The only difference I find is that the "extent" changes in the metadata. What I understand is that this change with the reprojection, is not independent of change with respect to CRS.

I'm I missing something so obvious ?

I followed previous posts without success: - Same crs, different spatial reference system units, shape files / QGIS - Adjusting extents so that same-CRS shapefiles overlap in QGIS? -Why do my Shapefiles not align correctly?

same CRS different extent.

7
  • The data in question says EPSG:4686, but also is this a public WMS that other users can test on? If so, please provide the source of the WMS if possible. Another question - when you "changed" the CRS to EPSG:3116, how exactly did you do that? Can you outline those steps in your question?
    – SaultDon
    Sep 21, 2016 at 20:20
  • no, sorry is not public. the EPSG:4686 is presented on the first windows but, to be added I picked 3116. No matter which I use this first layer is not overlapping. I changed CRS by right-click/save as .../ or Layer/save as.. @SaultDon Sep 21, 2016 at 20:34
  • correction: EPSG:6247 is on the first windows when Im about to add the layer from the WFS. I re-project all layers to 4686 because is the projection that I know is working. (most of my layers(vectors and rasters) render well on it) @SaultDon Sep 21, 2016 at 20:45
  • If I take coordinates in 6247 (MAGNA-SIRGAS / Bogota urban grid) (could be 3116 also) but unproject them to lat-lon using 21897 (Bogota 1975 / Colombia Bogota zone), I get points at lat=-3, lon=-8. parquesurbanos4686 was created by unprojecting it incorrectly somehow. Mainly the false easting/northings are different which causes the big offset.
    – mkennedy
    Sep 21, 2016 at 21:47
  • does this mean that the "original" layer - the one from WFS - wasn't projected properly when it was created? isn't solved after changing the projection?@mkennedy Sep 22, 2016 at 2:24

1 Answer 1

2

The EPSG code 6247 is not in the CRS database of QGIS, so the WFS gets a different CRS assigned, probably as a custom CRS.

You have to look up the Layer CRS of the WFS layer with rightclick on the layer Set Layer CRS before reprojecting to any other CRS. Most probably some parameters have been gone astray.

QGIS offers EPSG:3116 for the Bogota zone, with these parameters:

+proj=tmerc +lat_0=4.596200416666666 +lon_0=-74.07750791666666 +k=1 +x_0=1000000 +y_0=1000000 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

Fasle Easting and Northing differ against the definition of EPSG:6247 at https://www.epsg-registry.org/

Creating a grid in EPSG:3116, the city of Bogota and two of your layers are around X=1000000 Y=1000000, while the parquesurbanos layer (in red) is around X=100000 Y=100000:

enter image description here

That makes me think the coordinates of the false Easting and Northing are missing or in wrong units.

To sanitize your data, overlay the WFS on Openstreetmap background, and see if it is still in the right place. If not, you have to create a new custom CRS and assign it to the WFS before reprojecting to any other CRS.

As an example, I created this custom CRS:

+proj=tmerc +lat_0=4.596200416666666 +lon_0=-74.07750791666666 +k=1 +x_0=100000 +y_0=100000 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs

reprojected the parquesurbanos layer to EPSG:3116, and assigned the Custom CRS with this result in green:

enter image description here

It seems to fit inside the extent of the other two layers. If the data still does not align to an OpenStreetMap background, take the parameters of EPSG:6247 from the EPSG registry which are slightly different.

Exchanging the .prj file does not help with QGIS, since it cretaes a .qpj file as a backup for CRS information. You better delete that if you assign a different CRS.


From C:\OSGeo4W64\share\proj\epsg: Unable to translate coordinate system EPSG:6247 into PROJ.4 format.. The projection method is not implemented in PROJ.4/GDAL The EPSG registry notes a parameter Projection plane origin height which can not be expressed using proj.4 methods.

1
  • trying to overlay with openstreetmap in fact confirmed it was not in a correct projection. I did the custom CRS just copying the EPSG:3116 and changing +x_0=1000000 +y_0=1000000 to 100000. Every layer from WFS was added using my custom CRS (at this point it was overlapping properly) and then reproject to 3116. Now it works. @AndreJ Sep 23, 2016 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.