4

I'm trying to load up a set of shapefiles in QGIS, to undertake a points in polygon analysis. I load up the points in OSGB 1936 / British National Grid (EPSG: 27700) (the same as the polygons), however they do not appear. I've enabled 'on the fly' transformations. See a screenshot below with no visible points layer:

I've opened another project with the points in WGS 84 and then saved them in the transformation required (EPSG: 27700). Still no luck.

I then opened them in Arcmap and they worked fine, see below:

enter image description here

I'm all out of ideas, are there any other suggestions for how to get this working in QGIS?

EDIT: See the requested metadata for the points layer below:

General
Storage type of this layer
ESRI Shapefile
Description of this provider
OGR data provider (compiled against GDAL/OGR library version 2.0.2, running against GDAL/OGR library version 2.0.2)
Source for this layer
C:/Users/ejo31/Desktop/cell.ID.locations/open.cell.id.27700.shp
Geometry type of the features in this layer
Point
The number of features in this layer
1332599
Capabilities of this layer
Add Features, Delete Features, Change Attribute Values, Add Attributes, Delete Attributes, Create Spatial Index, Fast Access to Features at ID, Change Geometries, Presimplify Geometries, Presimplify Geometries with Validity Check
Extents
In layer spatial reference system units
xMin,yMin -99.7747,-44.7261 : xMax,yMax 174.781,76.6116
Layer Spatial Reference System
+proj=tmerc +lat_0=49 +lon_0=-2 +k=0.9996012717 +x_0=400000 +y_0=-100000 +ellps=airy +towgs84=446.448,-125.157,542.06,0.15,0.247,0.842,-20.489 +units=m +no_defs
  • Can you add the extent of the points layer, as reproted by rightclick on the layer -> Properties, Metadata tab, properties section? Most probably they still are in degrees, not EPSG:27700 British National grid in meters. – AndreJ Sep 26 '16 at 13:50
  • I have now done this AndreJ. Any ideas? – Thirst for Knowledge Sep 26 '16 at 14:13
  • I can see all the points clustered west of the scilly isles - look at gis.stackexchange.com/questions/183558/… – Mapperz Sep 26 '16 at 14:29
7

From the metadata I can see that the coordinates are in WGS84 for the points but somehow the projection is set to OSGB. This is why the points all appear near the Scilly isle as that is near the origin of OSGB and your coordinates being in decimal degrees will all appear down near 0,0.

If when you load your points layer it asks for the CRS, don't tell it OSGB (which is wrong and I believe is the mistake you are making), but tell it WGS84 (which is the correct CRS for the data). If it doesn't ask for a CRS, then delete the PRJ file of the shapefile as this has become corrupted by your attempts to set the CRS.

  • Yes, I fixed it by importing the points csv file again as WGS 84, and then saving it as a shape file. I then opened the other polygon files in the OSGB CRS and imported the points, and it did the on-the-fly transformation. Thanks! – Thirst for Knowledge Sep 26 '16 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.