1

I am using ArcGIS 10.4.1 to convert a polygon feature class to a raster dataset and I would like the cells to line up with an existing raster layer. I am running the feature to raster tool and using the existing raster layer as a reference for the cell size and as the snap raster. However, my output raster cells are still offset as seen here:enter image description here

Any other suggestions for getting the cells to line up? I have double checked that my existing raster and feature class are both in the same projection.

Update - I also tried the suggestions in the answer listed here: https://geonet.esri.com/thread/98483

I turned off background processing and used data from straight from the catalog and am receiving the same result.

5
  • What software are you using? or what software do you have available to use? Sep 26 '16 at 13:51
  • I am using ArcMap 10.4.1. I have edited the original question to reflect this.
    – mmoore
    Sep 26 '16 at 13:53
  • Well ... I was going to craft an answer based on using your original raster as a snap raster and also to set the cell size but it seems you are already doing that so I'm pretty flummoxed. I think I'd call ESRI support in a case like that. Are they also already in the same projection? - Ah - I see that now too. harumph! Sep 26 '16 at 13:56
  • Yes, both layers are currently in the same projection. Yeah, I'm also a bit surprised as to why they are not lining up.
    – mmoore
    Sep 26 '16 at 13:58
  • Can be just a visual thing with rasters, see if raster to polygon confirms mismatch
    – FelixIP
    Sep 26 '16 at 19:40
2

Before running feature to raster, go into your 'Environment Settings' (access via 'Geoprocessing' tab) and set a 'Snap Raster' (under 'Processing Extent'). Under 'Raster Analysis' set your 'Cell Size' as the Snap Raster. Then run Feature to Raster. If that doesn't work, try processing the raster with another tool (e.g., raster calculator) after feature to raster. Also try in a new map document.

5
  • I tried all of these suggestions (several times and from a couple new map documents) with no success, unfortunately.
    – mmoore
    Sep 26 '16 at 14:58
  • Do all of above and raster calculator on results
    – FelixIP
    Sep 26 '16 at 17:29
  • perhaps raster structure matters? it's working for me using .tif Sep 26 '16 at 17:54
  • As FelixIP mentioned, try running some other process on the raster (e.g. raster times 1). Sep 26 '16 at 18:02
  • Jus "raster" will do, no need to apply any transformation
    – FelixIP
    Sep 26 '16 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.