2

I have two servers (both windows VMs). ArcGIS Server and Desktop are installed on ServerA. ServerB is where all the data is stored (various SQL databases including 1 SDE, and folders).

We have a shared folder on ServerB that a number of images are stored in, this folder needs to be registered with the ArcGIS Server so we can publish the data in this folder.

The path to this folder on ServerB is C:\ImageStore[Data], and ImageStore is the shared folder. I have mapped to this folder from Server A calling it Z:\, and can access the data no problem.

However when I try to register this location with ArcGIS Server it fails, see image:Data Store Registration Fail

I have tried every combination of 'Publisher Folder Path:' and 'Publisher Folder Hostname:' I can think of in the boxes above; not using the drive letter but the UNC path instead, including the share folder name in the path, using server.domain.com, and various formats of the above, all to no avail.

The mapped folder can be connected to in ArcCatalog on ServerA with no issues, so the images can be viewed in ArcMap.

The folder has no security restrictions on it at all, completely open permissions.

About halfway down this page, there is an image that indicates what I am doing should work. The ArcGIS Server help doc also says you should be able to register a network folder.

Has anyone had any success doing this?

ArcGIS Server and Desktop are version 10.2.2.

  • 1
    Does the account running ArcGIS Server "See" and is really setup to connect and use that drive? Unless ArcGIS Server is running under the account you're logged in as and testing with, you cant really confirm that it sees that drive. – KHibma Sep 26 '16 at 20:03
2

Got it working, didn't use mapped drive letters at all, just UNC server name in the Publisher Folder Path:. The ArcGIS Server account has to be explicitly listed has having permissions on the folder on Server B. Even though the folder was set to allow all users access that won't work. Which means the ArcGIS Server account needs to exist as a user on Server B.

  • Mark your answer as resolved please – Simon Nov 11 '16 at 23:38
  • Server accounts do not sign on as a user, so they won't have mapped drive letters available. That's why you must use the UNC path when configuring a service account to use a network share. – mwalker Mar 24 '17 at 17:40
  • @mwalker, wondering if a solution like this is an option: stackoverflow.com/questions/182750/… – Map Man Mar 23 '18 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.