1

I want to find the shortest route connecting three points on a map. I built up a road network, I snapped three points on the road.

I got this error:

Warning: No route from location "Location 1" to location "Location 2". Error: No solution found.

enter image description here

I can find the road between point 1 and 3 (of the first map), but I got that error for the road between 3 and 2 and 1 and 2. The road between 1 and 3 does not even look like it is the shortest path (see below).

enter image description here

Is it possible that can depend on some routes feature that does not me allow me to drive through those? so I can't reach the point 2 and I don't take the shortest roads.

The procedure I followed:

1) I snapped the points to the road as described here: https://gis.stackexchange.com/a/1433/73176

2) I created the network from the road polyline similarly to this tutorial: http://desktop.arcgis.com/en/arcmap/latest/extensions/network-analyst/exercise-1-creating-a-network-dataset.htm

3) "Network Analyst" --> "New Route"

4) Right click on "Stops", "Add locations.." I added the three points

5) "Solve"

  • 1
    It seems likely to me that there are gaps in the network i.e. snapping errors - how confident are you with the data? Can you update the question with the exact tool and parameters you used? – Dùn Caan Sep 28 '16 at 10:17
1

Once upon a time I've got the same problem, and I solved it by planarization.

Here is a documentation: http://pro.arcgis.com/en/pro-app/help/editing/planarize-polyline-features.htm

Just planarize your polyline layer and then you should get "clean" network without any intersections.

  • I don't know why but the planarization button stays unactivated and I can't proceed. – ales.singli Sep 28 '16 at 11:50
  • the projection of the road was different, so I converted it to my layers projections and the the planarization worked. It looks like it's working well now, better than before for sures, I will try also with other points to confirm it @dmh126 – ales.singli Sep 28 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.