3

I realised that exporting a huge amount of building polygons (in my case 86,000 polygons) to a A2 PDF within ArcGIS 10.2.2 the polygons get unacceptably jagged or even reshaped. It gets a bit better if the dpi value is set to a higher number (e.g. 1000) but it's still not the desired quality.

Polygons within my ArcMap data frame: Polygons within my ArcMap data frame

Polygons after export to a PDF (400 dpi): enter image description here

Is there a way to avoid this problem?

  • 1
    Try printing using ArcPress – GISGe Sep 30 '16 at 11:43
  • Thank you for commenting but I only have version 10.2.2. – zehpunktbarron Sep 30 '16 at 11:46
  • It's been there since at least version 9. – GISGe Sep 30 '16 at 11:47
  • Ok, I must have overlooked that. However, I want to export my map to a pdf and do not want to print it and can't find a way to do this following your link. – zehpunktbarron Sep 30 '16 at 11:56
  • 5
    It looks like your polygons are being rasterized. You should check to see if you have any layers above the polygons in your TOC that are rasters, have transparency or are using bitmap symbology; if so see if you can put your polygons above them in the TOC. – johns Sep 30 '16 at 12:29
0

Finally, with the help of the comments above and try and error I could minimalize the error. The following has helped:

  • It was no difference between "export map" and exporting via "printer".
  • As suggested by johns in the comments section place the polygons above all other (transparent, raster) layers in the TOC
  • Set the DPI to 3000. Unfortunately this leads to a huge PDF size.
  • However, there are several factors to reduce the file size within the pdf export options:
    • Set resample ratio to 1:2
    • Uncheck "Export Map Georeference Information"
0

@johns put his finger on the biggest culprit, your polygons are being rasterized. Check to see if you have any layers in the Table of Contents above the polygon layer which are:

  • rasters
  • have transparency set
  • or are using bitmap symbology (picture fills)

If any of these are true, move your vector layer above them.

After that, ways you can further improve PDF and print export are:

Summary: best quality, jpeg 85%, vectorize markers

Summary of best options selected in dialog

Plus: PDF layers only (no attributes) if you wish readers to have ability to toggle layers on/off, or no layers if you need smaller file size.

Explanation

The export Output Image Quality slider (normal, normal + 1, best) affects jpeg artifacting around transparent colour fills

normal+1 setting and result

Jpeg quality slider has little observable effect above 95% while the file size jumps 25% at 100 quality. Sweet spot is 85-95%.

jpeg quality slider

Converting bitmap markers/fills to vectors instead of raster is a no-brainer. The raster markers are horrible no matter what quality is chosen on the first option page. vectorize option setting

Raster and Vector marker results


Fills and transparencies will always look better in Arcmap than in the exported pdf. Text and fine lines on the other hand can be darker and crisper in Adobe Reader.

The PostScript Printer engine is the only one which maintains crisp and smooth curves on the text. All others have little bumps and dips, which won't make much difference in hardcopy but are visible at 200% zoom.

Screenshots below
Top left: Normal+2 quality, jpg 85%, vector markers
Top right: Normal+1 quality, jpg 90%, vector markers
Bottom left: Normal+1 quality, jpg 85%, vector markers
Bottom right: Normal+1 quality, jpg 85%, raster markers

The jaggedness seen in the rose coloured buffer is because a transparency effect is being applied to that layer. Remove the effect, remove the jaggies.

Detailed screenshots of various settings


Missing: the effect "convert marker symbols to polygons" has.

convert marker checkbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.