4

I'm having problems with SAGA GIS. It segfaults on launch, either from the command line or when called from QGIS.

If I run saga_cmd using gdb, I get this error:-

(gdb) run
Starting program: /usr/bin/saga_cmd 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
____________________________

   #####   ##   #####    ##
  ###     ###  ##       ###
   ###   # ## ##  #### # ##
    ### ##### ##    # #####
 ##### #   ##  ##### #   ##
____________________________

SAGA Version: 2.2.7

[New Thread 0xb1dbbb40 (LWP 14864)]
[New Thread 0xb15bab40 (LWP 14865)]
[New Thread 0xafdb9b40 (LWP 14866)]

Program received signal SIGSEGV, Segmentation fault.
__strlen_sse2_bsf () at ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S:50
50  ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S: No such file or directory.

My setup:-

  • Ubuntu Tahr 32bit
  • QGIS 2.16.3 . This is a fresh install. Using the standard QGIS install as defined here. This is the Stable release, and not UbuntuGIS.
  • QGIS Running against GDAL/OGR 1.11.2.
  • QGIS Compiled against GDAL/OGR 1.10.1
  • SAGA 2.2.7

I found this discussion, which suggests it's the version of GDAL i'm using. This seems to tie in with when this problem first started - when GRASS 7 support started working for me from QGIS.

Is there a way around this? If GRASS and SAGA need different versions of GDAL, I'm worried that attempting to fixing this for SAGA might break GRASS 7 support, which I also need.

3

Yay! Found a solution...

  • I used sudo synaptic to nuke all traces of SAGA from orbit (It's the only way to be sure..)
  • I removed the line deb ppa.launchpad.net.johanvdw/saga-gis/trusty/main from my sources.lst (no offence to @johanvdw - your packaging got me up and running with SAGA with QGIS in the first place)
  • reinstalled SAGA from the Ubuntu Software Centre.. I now have 2.1.4 installed

Now I can use SAGA from QGIS with no problems, and GRASS7 plugins work too.

____________________________

   #####   ##   #####    ##
  ###     ###  ##       ###
   ###   # ## ##  #### # ##
    ### ##### ##    # #####
 ##### #   ##  ##### #   ##
____________________________

SAGA Version: 2.1.4

Error: no arguments for saga call
Error: select a library

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.