5

When trying to edit a vector layer using node tool, i get constantly the next message:

Indexing data

Normally it appears once at the beginning of the edition and then it doesn't show any more, but now I get it constantly. It blinks very fast and I can't even edit the line.

I've tried to save this layer again as another shapefile. I have closed and re-opened the software. I have disabled all the plugins (just in case it's a matter of memory or rendering). None of this tries solved anything.

It is not the only layer where this happen, so I think the problem is not a corrupted file (or maybe everything is corrupted).

Anybody knows why this is happening and how to solve it?

(QGIS 2.8.6 on Windows 7)

  • Try Layer Properties > General > Create spatial index. Note that you're using quite an old version of QGIS so not sure if this option is available... – Joseph Oct 5 '16 at 14:06
  • I've tried your solution, which is enabled in the version I'm working with, but the problem persists. I've tried the solution proposed by Matthias and it helps a little, but still doesn't solve completely the problem. – Andreu Amoros Oct 5 '16 at 14:24
3

It's caused by snapping. I guess you could disable that.

Upgrading QGIS might be the better option though, I'm quite sure it has been solved in newer versions.

  • I know I'm gonna sound very newbie, but: ¿if I upgrade my QGIS version to the last LTR version, can I keep working with my project or I'm gonna have problems? (I ask that because the deadline of the project I'm working in is in a couple of weeks, so I'm afraid of having to adjust too many things) – Andreu Amoros Oct 5 '16 at 14:20
  • 1
    Normally it's not much trouble. But to be on the safe side, install the version in parallel and try to work on a copy of your project file first. – Matthias Kuhn Oct 5 '16 at 14:25
  • Thanks for your suggestion, I think I'm going to try it. Moreover, the solution you proposed (disable snapping) worked just at the beginning. I imagine there isn't anything better... The fact is that some time ago, this problem wasn't there. I don't know what could have happened. – Andreu Amoros Oct 5 '16 at 14:33
  • Finally it was a snapping problem, you were right! The problem was that something went wrong and even if I turned off snapping, it continued working in the background. So what i've done is selecting "advanced options" in the snapping menu and disable it for all the layers and everything worked fine! – Andreu Amoros Oct 6 '16 at 15:25
2

It can also be caused by Show Feature Count in the Layers Panel. Uncheck it, if it is checked.

  • I have this panel already unchecked. I don't know what can cause this issue. – Andreu Amoros Oct 6 '16 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.