4

I'm trying to reproject a flat lat/lon image into geostationary projection.

The input data is 1441x1441 pixels and covers the region -90 -> 90 lat and lon. The output data should be 3712x3712 pixels in GEOS projection centred upon 0.0 degrees longitude (i.e: Meteosat/SEVIRI full disk).

I run gdalwarp with this command on a land/sea mask input image:

gdalwarp -t_srs '+proj=geos +a=6378169.0 +b=6356583.8 +lon_0=0.0 +h=35785831.0' -te -5568748.276 -5568748.276 5568748.276 5568748.276 -tr 3000.403165817260742 3000.403165817260742 -multi -r cubic  tmp_in.tif tmp_out.tif

And I get this output (land/sea boundaries added in red): enter image description here

As you can see, the actual georeferencing looks OK, but parts of the image are missing: Such as Greenland, the western parts of South America and also Antarctica. These are all present in the input data file, but for some reason gdalwarp is cutting them off in the output.

Any ideas what the heck is happening here? I've tried various combinations of -te, -ts and the -t_srs projection without luck.

  • Possible duplicate of gis.stackexchange.com/questions/70207/…. Using a sphere instead of an ellipsoid might help too. – AndreJ Oct 11 '16 at 6:15
  • I don't use QGIS so that's not the reason. Have also tried with a sphere instead of an ellipsoid (despite that being the wrong projection for GEOS) and the problem remains. – os1 Oct 11 '16 at 6:39
  • 1
    QGIS uses GDAL in the background as well, so clipping to the visible extent should solve the problem. gdalwarp -wo SOURCE_EXTRA=1000 might help too to avoid artefacts. – AndreJ Oct 11 '16 at 7:34
4

As per @AndreJ's comment, adding -wo SOURCE_EXTRA=1000 to the gdalwarp call cured the problem.

For reference, this appears to be an issue with newer versions of gdalwarp. My code works fine on old versions of gdal but not on 2.1, if any other users encounter this problem then try the above suggestion.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.