4

I'm working with shapefiles of water protection areas (of Germany) to find out weather or not somme geocoded adresses are inside of these areas.

Every federal state delivers shapefiles in a different CRS and I usually solve this by choosing "Save As" to project them in my Project CRS (EPSG 4326) before further processing them.

The file for "Baden Würtemberg" however aborts with an Error message when I try to do this.

Link to the source of the shapefile: http://udo.lubw.baden-wuerttemberg.de/public/pages/url/show.xhtml?url=http%3A%2F%2Frips-dienste.lubw.baden-wuerttemberg.de%2Frips%2Fripsservices%2Fapps%2Fgeodatenexport%2Fudo%2Fdownload.aspx%3Fid%3D32

Error message when "Save As" is used:

Export in Vektordatei schlug fehl. Fehler: Objektschreibfehler: Objektgeometrie nicht importiert (OGR-Fehler: ) Objektgeometrie nicht ... importiert (OGR-Fehler: )Abbruch nach 1001 Fehlern

translated:

Export to shapefile failed. Error: object writing error: Object geometry not imported (OGR-Error: ) abort on error number 1001


What I tried so far:

  • I can "Save As" other shapefiles from and to the chosen directory. I also tried creating a new QGIS project with the shapefile directly on the desktop (so its not a permissen problem).
  • "Save as" doesn't work when not changing the CRS as well
  • I checked with "validate geometry" and eliminated all the errors by deleting duplicate nodes and overlapping areas of the shapefile. Different shapefiles with non-valid geometry can be saved too.
  • Save to a file without critical signs like spaces, umlaute (ä,ö,ü,ß).

Any ideas where this error comes from?

Am I missing out some problem with the original shapefile?

Maybe you could try to reproduce this to find out if the problem is in the original shapefile itself or caused by my GIS-configuration.


Using QGIS-2.10.1 on Win7. I'am stuck with these specs for now, will try with newer QGIS version and report back later.


Back home it works with QGiS2.8.6. Maybe there is an bug only in 2.10.1 or, more likely, I missed something.

closed as off-topic by underdark Oct 11 '16 at 19:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Which QGIS version and platform are you using? I can confirm this works fine for QGIS 2.16.1 for Windows 7 64-bit. Here is an image. – Joseph Oct 11 '16 at 11:55
  • 1
    Did try it with 2.14.7 on Win7 64bi tand the downloaded data and can´t reproduce the error. Maybe you have a corrupt installation? – Matte Oct 11 '16 at 12:04
  • 1
    Did you save to a different filename? It works for me even with QGIS 2.8.3. – AndreJ Oct 11 '16 at 14:27
  • Maybe the source-shapefile still had an Umlaut "ü"... I only checked the filename I gave the new layer.... thanks Andrej – Papierwolf Oct 11 '16 at 17:15
  • @Papierwolf even saving as BaWü.shp works for me. – AndreJ Oct 12 '16 at 11:33