When I try and use the dissolve tool (vector>geoprocessing tools>dissolve) QGIS 2.16.3 crashes and produces a minidump file. This is with any shapefile that I use. I have also tried it on a friends 2.14.3 and the dissolve process works fine for the same files that I tried.

Dissolve Screen Shot


Try to do clean uninstall of your QGIS software and install it again. To do clean uninstall you can follow the instructions on the question: How to completely uninstall and remove QGIS 2.8.1?. Then install the updated QGIS LTR version of 2.14.7 instead of QGIS 2.16.3, maybe it will solve your problem.


I encountered the same issue a few days ago. A possible workaround is to use the GDAL module (accessible through the processing panel). Both GRASS and SAGA also have tools to dissolve the polygons.

A possible cause for the crash might be linked with the topology of the file, do some of your polygons overlap? I remember an error message linked with that, not sure where though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.