5

In the example shown in the picture below I would like to split the light blue polyline into two polylines on a specific node (circled with number 1) with QGIS (version 2.12.3-Lyon).

Given that the layer is already editable, and given that I have set the snapping options at 1 map unit tolerance and snap it to vertex, which tool should I use, number 2 or number 3? (I get the names in Spanish and the picture seems easier to identify for anyone).

How do I select the node (number one) once the splitting tool is active? So far, if I just click on the node, the entire polyline disappears.

I understand the explanations already given by @Knightshound and @Joseph in answers to question 'Polyline split at node in QGIS' but need more detail into how to correctly proceed.

enter image description here

  • Strange that the line disappears on you. Like @ahmadhanb says, 2 should be used. Number 3 is for splitting parts in multi-features. If it disappears when using 2, try selecting the line and using 3. – Knightshound Oct 13 '16 at 9:20
  • Number 2 is the Split Features which splits your single part feature. Number 3 is the Split parts which splits your multi part feature (i.e. increasing the number of parts). Depending on whether your line is a single or multi part will determine which tool you use. – Joseph Oct 13 '16 at 9:21
2

Normally, I use snapping option of 10 pixels and it works perfectly, as you can see below:

enter image description here

Using Split feature tool with the above snapping option after selecting the feature that you want to split, the snapping and splitting works as expected:

enter image description here

The pink (+) mark is the snapping at the vertex location.

  • I did exactly as you mentioned and to actually split the polyline, once the vertex is selected (pink mark), I right click with the mouse. Then I get a message saying there are selected object (the polyline) and the tool only works for it (not the node I am selecting with the splitting tool, I suspect). – Pescariz Oct 13 '16 at 9:47
  • When I select the line to split at the vertex, I used the split tool mentioned above and split at the vertex using the left click on the mouse not the right click. It worked without drawing a red line. – ahmadhanb Oct 13 '16 at 13:09
  • Doing exactly as you say -left click - I get this message: "No se dividió ningún objeto espacial: Si hay objetos espaciales seleccionados, la herramienta de división sólo se aplica a éstos. Si quiere dividir todos los objetos espaciales bajo la línea de división, elimine la selección." Which more or less means: "no space object was divided: If there are selected features, the split tool will only applie to them. If you want to divide all space objects under the dividing line, delete the selection." Doing it with right click I loose the polyline. Maybe it's a matter of QGIS versions? – Pescariz Oct 14 '16 at 7:09
  • I just updated to QGIS 2.14 and it works exactly as you said, easy and smooth. It was a matter of versions. I just hope my answer can serve for someone who has an older version of QGIS. – Pescariz Oct 14 '16 at 8:04
  • I was wondering why it didn't work with you? But using different versions of QGIS can raise such issues. Glad it worked, and good luck. – ahmadhanb Oct 14 '16 at 8:15
1

I finally got my polyline split doing it this way:

1) Set the layer editable, set snapping tolerance = 10

enter image description here

2) Select polyline to be splitted (now in yellow)

enter image description here

3) Chose the splitting tool mentioned above (the one that splits single parts) and draw a -more or less- perpendicular line accross your target polyline trying to go on top of the node you want to make the split (its a very soft dotted oblique red line that I made for its better visualization).

enter image description here

4) Right click to settle your cut. Then half of the polyline changes color (now the right part appears blue, as it is no selected).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.