I have to convert from vector to raster so I used the Raster/conversion/rasterize tool. On my first try I used the Width (1447) and Height (2538) from the reference raster layer (1985clasification) on the raster size in pixel section in the rasterize window but the output layer differs on extent and pixel size. I tried a second time but changing the raster resolution in map.. based on the same reference layer and the output is the the same in extent from the first result but quite different in the way is rasterized. different extent and pixel size I also tried to manually edit the gdal rasterize command using the -te parameter to see if I was able to match the extent but the output was completely different.

I followed the suggestion in a previous question but the extent of output layer keeps the same and it seems to lose information.

Via GRASS something is not working with my mapset so the vector is not listed and I decided to decline.

Am I using the wrong parameters ? Do I need to include something else?


I managed to set the pixel size and extent. First the rasterize tool, then the raster calculator. Nevertheless the output (at least visually) is different. I assumed that the smaller raster (the one transformed from vector) is because the original does not have information beyond its own limits where the bigger raster does. How is possible for this two rasters to have same values and look like that?enter image description here


Checking the images outside Qgis seem to have the extent it should have.

I was not able to see the full extent because those are null values? or because the way it renders with layers beneath them?

Now there is a white frame on both images (on the left). Why the process of resampling end up with this? is it possible to remove it? enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.