1

I am trying to combine a whole bunch of rasters with ArcGIS Spatial Analyst. Seems to be doing what I want EXCEPT the calculated output is only the area where all 4 rasters overlap.

I am new to this, and don't know what I'm doing wrong!

Using 9.3.1

3

In the tool click on the Environments button at the bottom. This will bring up a new set of menus where you can set various parameters for running the geoprocessing tool. Under general settings change the Extent setting to Union of Inputs instead of Intersection of Inputs (the default for raster data).

Note that the intersection of these datasets is the default becuse without the data coverage results in different areas mean different things.

  • thanks! i did have this set to 'union of inputs' and on inspection, where my rasters are not overlapping, the values are coming out 'no data' - is there something else i have missed? – 0_T Mar 14 '12 at 7:03
2

And/Or use one of the Mosaic functions in the Data Management toolbox instead of Spatial Analyst. Esri has a couple of options depending on your use-case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.