1

An Esri blog entitled Put Your Best Thumbnail Forward has instructions for how to edit an ArcGIS Online map to change its thumbnail image.

Using those I perform the following steps to try and change the thumbnail for an ArcGIS Online Web Mapping Application without success.

  1. Sign into my ArcGIS Online Public Account
  2. Click on My Content tab
  3. Click on the Web Mapping Application to open its item details
  4. Click on Edit Thumbnail
  5. Browse to the image I want which is a *.jpeg 200 pixels wide by 143 pixels high which seems to be OK according to the instructions below (I also tried renaming it as *.jpg).

For best results, the image should be 200 pixels wide by 133 pixels high. Other sizes will be adjusted to fit. Acceptable image formats are: PNG, GIF and JPEG.

  1. Click OK
  2. Thumbnail does not update so I hard refresh the browser and it still does not update.

Is it possible to change the Thumbnail used for a Web Mapping Application that is being shared using a Public Account of ArcGIS Online?

  • 1
    Sounds like a potential bug. Guessing that because Public accounts have restrictions on storing content in AGO, a thumbnail might also fall into that category. Recommend raising with Esri support. As a side-note. a free ArcGIS Developer Plan offers a lot more options than a public account and might be more useful for you? It would solve this issue for starters. – Simon Oct 15 '16 at 3:14
  • @Simon I suspect the Public Account may have this as an undocumented limitation. I could try working around this a Developer Plan or by using my ArcGIS Online for Organizations but the particular thing that I wanted to do this for is aimed at home users. I could just suggest those home users sign up for Developer Plans too, but that would beg the question as to why anyone would want a Free Public Account if they could get a Free Developer Plan just as easily? – PolyGeo Oct 15 '16 at 5:04
  • 1
    I would still encourage raising it with support as a potential bug. A public account can create apps, so they should be able to represent those apps with the appropriate thumbnails. Depends on use-case - public accounts are easier to create/login (Google/Facebook login) but I am a big fan of pushing developer plans at users. You don't have to be a developer, and the terms are not limiting for a lot of use-cases. developers.arcgis.com/terms – Simon Oct 16 '16 at 6:07
  • 1
    I couldn't reproduce your issue using a public ArcGIS account, clicked on edit thumbnail, and the thumbnail is updated and refreshed the page and the new thumbnail was still present. What browser and version were you using? – Russ Roberts Oct 18 '16 at 18:05
  • @RussRoberts I should have tried *.png because I just pulled my *.jpeg into Paint.NET and saved it as a *.png and it just worked! My browser is Chrome 54.0.2840.59. – PolyGeo Oct 18 '16 at 19:30
0

I was able to achieve this by editing my *.jpeg in Paint.NET and then saving it as a *.png.

As soon as I tried the same procedure described in the question using the *.png in place of the *.jpeg or *.jpg, it just worked!

When I can find time I will try to report this to my local Esri support as something that I believe to be a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.