1

I have been searching for similar problems however i did not find any that could fix my error. i have GRASSGIS 7.0 running on MACOSX El Capitan. No problems at all until i tried to run i.pansharpen on Landsat 8 images.

this is how i set it (no optional values) i.pansharpen settings

it tooks a very long time almost freezing on

i.pansharpen --overwrite red=LC80340432016029LGN00_B3@PERMANENT green=LC80340432016029LGN00_B2@PERMANENT blue=LC80340432016029LGN00_B1@PERMANENT pan=LC80340432016029LGN00_B8@PERMANENT output=2016_pan_ method=brovey Performing pan sharpening with hi res pan image: 15.000000 Histogram matching... Histogram matching... Histogram matching... Calculating Brovey transformation...

then after a while it goes like this:

Performing pan sharpening with hi res pan image: 15.000000 Histogram matching... Histogram matching... Histogram matching... Calculating Brovey transformation... Assigning grey equalized color tables to output images... Traceback (most recent call last): File "/Applications/GRASS-7.0.app/Contents/MacOS/scripts/i .pansharpen", line 452, in main() File "/Applications/GRASS-7.0.app/Contents/MacOS/scripts/i .pansharpen", line 319, in main flags="e", color='grey') File "/Applications/GRASS-7.0.app/Contents/MacOS/etc/pytho n/grass/script/core.py", line 395, in run_command return handle_errors(returncode, returncode, args, kwargs) File "/Applications/GRASS-7.0.app/Contents/MacOS/etc/pytho n/grass/script/core.py", line 313, in handle_errors returncode=returncode) grass.exceptions.CalledModuleError: Module run None ['r.colors', '--q', '-e', 'color=grey', 'map=2016_pan__red'] ended with error Process ended with non-zero return code -11. See errors in the (error) output.

after that the output is created empty...

i do not understand what is the error, and how i could fix it, i have been extensively searching for a similar problem but couldn't find anything.

  • Can you edit your text to provide an actual question. At the moment it isn't clear what you are asking. – nmtoken Oct 15 '16 at 8:30
  • Sorry you are right, the last part was cutted when i published the question. – Fabio Favoretto Oct 15 '16 at 18:14
  • This is only a wild guess, but have you tried with different output file name? I also have a (different) problem with grass on fresh installed system, it isn't that stable – adamczi Oct 15 '16 at 21:32
  • @adamczi not so wild as guess, i tried because output names gave me problems too in the past, also i tried to run in serial processing rather than parallel, to allow overwriting files, tried all three methods, different landsat bands, different landsat files... nothing... same error... – Fabio Favoretto Oct 15 '16 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.