1

I have an application that uses Leaflet maps and I've overlayed some geoserver WMS layers (both point and Polygon). Now when I'm in at zoom 8 or more, etc the overlay looks accurate and exactly where it should be - but as I move out to zooms 7 and less I find my WMS layer seems to shift up more and more with each zoom level I go out.

The projection of the data is 4326 (WGS84). No errors, but as I said as you zoom out you notice the gradual shifting.

I am attaching an image for clarity. Can anyone help me solve this problem?

enter image description here

---------------------Update-------------------

Please find the url below. This url returns an image that gets overlayed on the map. It is at zoom level 4. Its a very elaborate code & I could not put it here. Hence, I am giving the link that gets generated through the code and the returned image gets overlayed on the map. Every time a pan or zoom happens a new image as per the new view port gets requested and the old one gets replaced by the newly requested one.

We have been using our own proprietary layer imagery generation code in the past. Our data used to be stored in SQL Server as geography data type. We never faced this problem. In case of boundless geoserver we can only work with geometry data type (geography is not supported). Now when we are substituting our proprietary layers with boundless layers we are seeing this problem. Not sure if there is a setting or something that I need to do while setting up the layers in boundless geoserver that would take care of this issue.

http://aaaa.bbbb.cccc.com:8080/geoserver/usa/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&FORMAT=image%2Fpng&TRANSPARENT=true&STYLES&SRS=EPSG%3A4326&LAYERS=usa%3ALayer1&BBOX=-152.40234375%2C27.839076094777816%2C-72.158203125%2C61.73152565113397&WIDTH=913&HEIGHT=569

  • please add some code so we can see how you added the WMS layer, most likely problem is that you are mixing WGS & Web Mercator – Ian Turton Oct 19 '16 at 8:53
  • I have updated the post to provide you more details. I could not paste the code here. I provided the url that generated the image. – Bose Oct 19 '16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.