1

In multiple files on multiple computers, I've tried to export a layer in my QGIS file as a DXF so that I can open it in AutoCAD. I've tried this for GPS located trails, contour lines, and a few other things.

I've tried right clicking the layer and using the Save As command and I've also tried the DXF Export from the dropdown menu.

It seems that no matter what I do, items that are scaled properly in QGIS get drastically scaled down when I save to DXF. Lengths that should measure close to a mile read as .0617 (or something like that) in a drawing where 1 unit = 1 foot.

What really confuses me is that I've tried multiple installs of QGIS on multiple computers and it's the exact same every time, but yet I haven't yet found anyone who has heard of this issue.

I can upload the file to a host if someone would like to dive into it and see if they can figure it out.

  • Try using the OGR Convert format tool from Processing Toolbox > GDAL/OGR > [OGR] Conversion > Convert format and set the Destination Format as DXF. – Joseph Oct 19 '16 at 12:56
  • It looks like it's only allowing me to select the raster layers in my file when I use this tool. I'm trying to convert vector layers to DXF. – H. Rigsby Oct 19 '16 at 13:19
  • There should be two tools: Translate (convert format) which is for rasters; Convert format which is for vectors. – Joseph Oct 19 '16 at 13:22
  • Okay, I found that. I exported it and it does the exact same thing. Same small size. I really don't think it has anything to do with how I export the layer. – H. Rigsby Oct 19 '16 at 13:43
  • Can you provide some native coordinates and the supposed position (city name and cournty for example) so we can check if it's correct (for that, use a fresh new qgis project and open the layer you want to convert, then read the coordinates. You can also read the extent of your layer in the properties/metadata > exemple : xMin,yMin -176.152,-54.792 : xMax,yMax 179.222,78.2). We also need to know the projection used for this layer. We'll have more hints this way. For the moment, I'm thinking like @Greg Z – gisnside Oct 19 '16 at 14:06
2

Your data is based on GPS measurement. This might indicate, that it has no projection defined and the coordinate reference system (CRS) is a geographic coordinate system. Coordinates are in degrees (latitude, longitude on a sphere)

You can check this, by looking at the bottom pane in QGIS. The center field in the bottom pane displays your current mouse position in map coordinates. If the are in a range between +90 and -90 (north/south) and -180 to +180 (west/east), the layer is not projected.

In order to transform your data to metrical / imperial units, you have to choose an procjection. More info can be found in the QGIS documentation on projection

UPDATE

There are some CRS using geographic coordinates. WGS84 GSC (SRID 4326) is one of them - GPS devices often use it. Your file is in NAD83 (SRID 4269), which is also a GCS. You have to transform it to a projected coordinate system in order to obtain distances in imperial / metric units (and not in degrees).

I found the file on Google (your link didn't work), with following description: "These data are distributed in geographic coordinates in units of decimal degrees, and in conformance with the North American Datum of 1983 (NAD 83)."

=> According to this + metadata, your file is in GCS (unless reprojected by you)

  • It's not this either unfortunately. The contours that I'm working with in this most recent file are geolocated. – H. Rigsby Oct 19 '16 at 13:16
  • I suppose I should add that they do have a defined CRS as well. They're from a USGS DEM that I converted into contours. – H. Rigsby Oct 19 '16 at 14:04
  • Please also specify the url of the source data if you got them from a public website :) – gisnside Oct 19 '16 at 14:09
  • I can't find specifically where I found the data again, but as I mentioned it is from a 2016 DEM map of Cooke County that was done by the USGS. – H. Rigsby Oct 19 '16 at 14:51
  • Found it: I used the "USGS NED 1/3 arc-second n42w088 1 x 1 degree ArcGrid 2016" DEM Raster from viewer.nationalmap.gov/basic/#productSearch. – H. Rigsby Oct 19 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.