3

I´m rather new to QGIS.

So the issue is this. I downloaded some terrain data from INEGI (Mexico´s Geographic Information Institute) which contained the contour slope.

I had no issue doing it with the original data downloaded from the site, I had the info and followed this simple tutorial to get the Interpolation Raster.

I had proceeded to join 4 maps using Vector->Data Management Tools-> Merge Vector Layers and had no problems after the merge.

Having merged for maps the resulting map came out to be rather large for an interpolation and for my project I needed high resolution. So I need to clip a section of those slope maps to generate a raster of only a part of the map.

So I did that, I created a new ShapeFile layer and created a rectangular polygon that determined the area to be clipped. Then I went ahead and used Vector->Geoprocessing Tools-> Clip.

Here you can see the low Resolution Interpolation of the larger Map and the Slopes that I will proceed to try and Interpolate

Having done this successfully I went ahead and used the exact same procedure to Interpolate this new slope and the error message I have been trying to solve for the past 3 hours appeared. "wkb access out of bounds".

This problem is exclusive to the "Triangular Interpolation (TIN)", Interpolation Method. While troubleshooting I tried the "Inverse Distance Weighing (IDW)" method which calculated somewhat successfully but with unsatisfactory results.

Interpolation Methods used

5
  • in your image does not appear that you defined the interpolation attribute. One thing also, sometimes INEGI for some reason stores the elevation data as text. I usually check the attribute table of the contour layers to check if the elevation data is stores as text or not. If so I use the field calculator to define a new integer field and multiply the text attribute times 1 and get the elevations now as a number. Commented Oct 21, 2016 at 0:51
  • I noticed also that in the first image that the project properties shows that is on "On the fly transformation" (OTF) mode. This indicates that you have layers with different CRS in your project. Try loading the merged contours in a new clean project and see if you face the same issue Commented Oct 21, 2016 at 1:01
  • Thanks Gerardo! I have had no problems with the CRS in my project. I wouldn´t have been able to clip or merge my layers if they have had different CRSs. After merging I have no problems interpolating, the issue is after clipping the same map I had interpolated just minutes before hand. I know of the problem you speak of. I create a "New Field" in the attribute table, set its type as INT and then copy the information from the "ELEVACION" column and refresh. No issue there. Commented Oct 21, 2016 at 1:45
  • Another solution is to download directly the DEM from INEGI's site at inegi.org.mx/geo/contenidos/datosrelieve/continental/… . There you can download the data at 15m, 30m, 60m, or 120m per pixel. I know this does not the issue you report but at least you may end with a DEM of the area of your choice Commented Oct 21, 2016 at 13:33
  • I worked around it setting the "current extent" in the interpolation settings. I had tried this before but it was buggy but worked after I restarted my computer. Still, I seek further understanding of this software and hope my query is answered. Commented Oct 21, 2016 at 15:53

0

Browse other questions tagged or ask your own question.