2

I created a Mosaic Dataset (Raster Mosaic) using ArcCatalog 10.3.1 and then added a number of existing Raster Mosaics to that Mosaic Dataset. I then edited the ZOrder of the constituent Raster Mosaics.

When I view my Mosaic Dataset in ArcMap the ZOrder does not appear to be having the desired effect. My smaller Raster Mosaics are visible when I zoom right in (large scale) but zooming out a bit (smaller scale) causes the smaller Raster Mosaics to disappear as they are covered by my large 'basemap' Mosaic. It's my understanding that this shouldn't happen as the smaller Raster Mosaics have a smaller ZOrder than the large basemap Raster Mosaic.

How do I get my smaller constituent Raster Mosaics to display at all scales without being covered up?

tl;dr after creating a Mosaic Dataset, adding rasters, and then editing the ZOrder, what is the next step to ensuring the raster display order actually follows the ZOrder?

2

Building overviews on the Mosaic Dataset generated what appeared to be incorrect MaxPS values. I manually edited the MaxPS values so that they were equal to the values stored in the HighPS field and this fixed the issue. In addition to changing the MaxPS values I've also set all of the MinPS values to 0.

I don't fully understand how MinPS and MaxPS are calculated but I do know (now) that they control the scales at which the rasters (and constituent Mosaic Datasets) are displayed within the Mosaic Dataset.

References:

http://tuinnovates.com/2013/05/22/beyond-default-settings-working-with-mosaic-datasets/ https://geonet.esri.com/thread/12216#comment-144376 http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//009t00000042000000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.