2

In QGIS 2.16.3, I have a point file, originally in the WSG84 (EPSG:4326) projection. I wish to determine the distance in km between each point in this point layer and intend to use the distance matrix tool to do this.
As WSG84 uses the unit dd, I first transformed my projection to what I believe is a metric transformation (Plate Carree (this was chosen as it was described in the QGIS manual as being proper when the goal is to measure distances)).

Problematically, when creating the distance matrix, the unit still comes out as dd, not km. I have also tried using the UTM transformation, with no luck.
After reading online, I saved my project (save as) and reopened it. Now, the drop down menu under Vector has changed, and I can no longer choose the distance matrix at all.

How do I calculate the distance between points in km?


I have now used the Save as function to save my point file in the UTM projection. But now the Vector drop down menu is altered, and I can no longer choose the distance matrix:

enter image description here

  • How did you "transform your projection" into Plate Carree? The distance matrix is under: Vector> Analysis Tools> Distance matrix. – HeikkiVesanto Oct 21 '16 at 11:47
  • I used Project proporties > Clicked the Enable 'on the fly' transformation, and choose the Plate Carree. And the distance matrix used to be just there, but disappeared after I opened the project in the Plate Carree projection. It is still there when reopening the WSG84 project, I find it very strange... – LHAndersen Oct 21 '16 at 11:52
  • 1
    The Plate Carree projection has been depreciated. Ideally you should use a UTM projection based on where your points lie as described in this post: QGIS distance matrix in meter instead of decimal degrees. You could also find the Distance Matrix tool in the Processing Toolbox. – Joseph Oct 21 '16 at 11:55
  • 4
    Using Properties> Enable on the fly, does not change the projection of your data. You need to reproject it. The easiest way to do this is the right click on the layer and choose "Save as..." and choosing the correct CRS at that stage. – HeikkiVesanto Oct 21 '16 at 12:13
  • 2
    @LHAndersen - Access it from the Processing Toolbox instead, this is where all tools are placed. I think recently they provided shortcuts to these tools in the Vector menu (which works for me but I am using QGIS 2.16.1). – Joseph Oct 21 '16 at 12:23
1

Delete the outdated version of the Processing plugin from your user folder at

~/.qgis/python/plugins/Processing

The new version of Processing is installed directly in the QGIS application folder but the old version in your user folder is masking it. That's why you are missing menu entries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.