12

in an attempt to import editable data to mapbox I fail to get the data imported in a form that the system accepts.

It rejects the data with an error message stating:

cities.geojson: Input failed. old-style crs member is not recommended on line 1.

When reading that I assumed somthing must have gone wrong with the conversion of my file, so I compared it to the sample file provided to MapBox without making out a difference.

Then comes the most confusing part: When trying to import the sample file I get a very similar error message from the system:

stations.geojson: Input failed. old-style crs member is not recommended, >this object is equivalent to the default and should be removed on line 1.

Now my question is: how can import a geoJSON file into MapBox?

  • 1
    You can probably open the GeoJSON file with a text editor and remove the crs element. You can write to MapBox and tell that they may be too strict with crs. geojson.org has links to current and 2008 versions of GeoJSON specification. – user30184 Oct 23 '16 at 14:33
17

Note that I am not a MapBox software user, but looking at the MapBox sample GeoJSON file you pointed out in Visual Studio, it appears the "crs" warning is related to the Coordinate Reference System element of the GeoJSON, at the very top of the file.

It might be that MapBox changed the import format specification, but forgot to update the sample file. I would recommend reporting it back to them using the "Ask our support team" link on the page hosting the sample file.

"crs": {
    "type": "name",
    "properties": {
      "name": "urn:ogc:def:crs:OGC:1.3:CRS84"
    }
  },

As to the problem: I would suggest to try and remove the CRS reference by using a text editor and subsequently try the import again. As said, I am not familiar with MapBox software, but I guess you will be able to define the CRS after the import in the software itself.

Be careful when editing the file, make sure the comma's and brackets are properly removed for the CRS object only! The top part of the MapBox sample GeoJSON should probably look like this:

{
  "type": "FeatureCollection",
  "features": [
    {
      "type": "Feature",
      "properties": {
        "name": "Van Dorn Street",
        "marker-color": "#0000ff",
        "marker-symbol": "rail-metro",
        "line": "blue"
      },
      "geometry": {
        "type": "Point",
        "coordinates": [
          -77.12911152370515,
          38.79930767201779
        ]
      }
    },

So the "type": "FeatureCollection", at the very top should most likely stay, as it is a separate object before the CRS definition.

  • 1
    Well that worked! Deleting the information about the CSR brought the data into the system. – Merlin Oct 23 '16 at 17:23
  • 1
    I can't believe such a company can't manage to "ignore" a line on a json file! – jdcaballerov Mar 2 '17 at 22:53
  • 2
    Just adding that @Marco_B's solution still works and MapBox has still not fixed this. – Valerie Anderson Apr 28 '17 at 13:46
  • This worked for me. Agree it's stupid that MapBox cannot fix this. – Meekohi Dec 7 '17 at 21:02
0

Yes - As posted above, you just need to edit the text file.

I removed:

"crs": {"type": "name","properties": {"name": "urn:ogc:def:crs:OGC:1.3:CRS84"}},

from the first line in my GeoJSON file and it imported fine.

  • How is this answer not a duplicate of @Macro_B's answer? – tinlyx Jan 26 '18 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.