1

I have a mosaic data set containing four raster images. I have published it on ArcGIS for server as a map service. I am applying Layer definition in export image interface at ArcGIS REST end. I have a text field on which I am applying the definition query. it works successfully in ArcMap but it doesn't work on Arcgis Rest Page of Export Map( showing Definition query is not working). I have tried with correct query and wrong query but it shows the image regardless of definition query.

I am using ArcGIS API for JavaScript 3.17 ArcGIS Server 10.2 ArcMap 10.4

EDIT

I can not share my arcgis server rest page. however for explaining my problem further i am using esri sample server.

  1. This link shows a basic map export.(without any definition query). Click here to see
  2. The second link shows a map export with definition query applied. Click here to see

See the difference in images.

This is how i want definition query to work, however in my case its giving the same result. Hope now my question is clear.

closed as off-topic by PolyGeo Oct 27 '16 at 22:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions seeking help to debug/write/improve code must include the desired behavior, a specific problem or error and the shortest code necessary to reproduce it in the question itself. Providing a clear problem statement and evidence of a code attempt will help others to help you. See: How to create a Minimal, Complete, and Verifiable example." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Please edit the question to specify how it "doesn't work". Since the client and server are two major (four minor) releases apart, have you considered that the desired functionality might have been introduced since 10.2.0? – Vince Oct 25 '16 at 10:46
  • Vince By definition query is not working i mean that data is shown regardless of definition query. – user4906240 Oct 25 '16 at 10:47
  • 1
    Does the server report an error message? "Not working" is an insufficent description. Please edit the question with details. Comments are only for requests for clarification. – Vince Oct 25 '16 at 10:52
  • There seems to be some code used but we are not seeing a code snippet to illustrate precisely what you have tested. – PolyGeo Oct 27 '16 at 22:15
  • I am first testing it on the rest end of arcgis server. i have added more details in my question. – user4906240 Oct 30 '16 at 6:11