Using QGIS 2.16.3, I wish to create a buffer zone around a single point in my multiple point file with a fixed radius of 5 km. Therefore, I made a selection and created a new layer only containing this point.
Next, I used Vecor -> Geoprocessing Tools to create a buffer zone with a fixed radius. Interestingly, the result is an oval buffer zone instead of a circular one, thus the radius is clearly not fixed, but flexible. What do I have to alter to make the bufer zone circular?

I have attached pictures of my input in the buffer zone tool, as well as a picture of my result.

Tool entry

enter image description here

Buffer zone

  • 4
    Are you in a projected or geographic coordinate system? It will only be a circle in the former. – PolyGeo Oct 27 '16 at 12:34
  • I use the WGS84 coordinate system, so I guess it should be an oval then. But when I use the Measure line tool, the radius is measured to be ~5km in NS direction, and ~10km in EW direction. Is it possible to create a circle with fixed diameter in a geographical coordinate system? – LHAndersen Oct 27 '16 at 12:40
  • 1
    Have a look at Tissot's circles blogs.esri.com/esri/arcgis/2011/03/24/…. – user30184 Oct 27 '16 at 12:44
  • 1
    If you created the circle with 5 km radius in EPSG:32632 then it really is 10 km in both NS and EW. The problem is that the measure line tool does not handle different scales in NS and EW directions when the map is in EPSG:4326. You can create a perfect circle in EPSG:4326, but at your latitudes it would be much larger in NS direction than EW direction then. – user30184 Oct 27 '16 at 12:48
  • @user30184 Thanks, that makes sense! I assumed the measure line tool worked equally in all directions, which was what had me confused. – LHAndersen Oct 27 '16 at 12:51

The buffer is round, but projected looking like an oval. This projection happens on-the-fly according to your QGis project CRS (see QGis Documentation).

Your screenshot says your input data is projected to epsg:32632, so will be the output. Make sure you project has the same projection and you'll see the buffer is really round. Click on the lower rigth button saying EPSG:1234? or see you project settings (Ctrl+Shift+P).

Not the answer you're looking for? Browse other questions tagged or ask your own question.