1

I have a submodel that takes 3 numeric parameters and one raster as inputs. I want to nest this in a second model that iterates through a folder of rasters. However, when I drag the submodel into the main model, only the raster input shows up as an input parameter (even though I've also marked the numeric inputs as parameters). How do I get the three numeric parameters to show up as inputs to the submodel in the main model? See screenshopts of the submodel (first) and main model (second) below.

sub model

main model

2 Answers 2

1

It's worth pointing out to others that your 3 numeric "parameters" are variables which are Preconditions to the calculate tools, so they are not classic inputs to a tool.

You can expose those variables in the sub-model in your master model. Once you have dragged your sub-model into your master model, right click on the sub-model (yellow box) and choose Make variable > from parameter > your variable.

1

Figured it out... Turns out parameters will not show up as input "bubbles" to the nested tool but rather simply as inputs in the tool interface when you double click on it (see photo).

submodel gui

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.