4

I've been trying to use the clipper tool in QGIS 2.18.0. However the following error message pops up;

Output driver `GMT' not recognised or does not support
direct output file creation. The following format drivers are configured
and support direct output:
GeoRaster: Oracle Spatial GeoRaster
VRT: Virtual Raster
GTiff: GeoTIFF
NITF: National Imagery Transmission Format
HFA: Erdas Imagine Images (.img)
ELAS: ELAS
MEM: In Memory Raster
BMP: MS Windows Device Independent Bitmap
PCIDSK: PCIDSK Database File
PCRaster: PCRaster Raster File
ILWIS: ILWIS Raster Map
SGI: SGI Image File Format 1.0
Leveller: Leveller heightfield
Terragen: Terragen heightfield
netCDF: Network Common Data Format
HDF4Image: HDF4 Dataset
ISIS2: USGS Astrogeology ISIS cube (Version 2)
ERS: ERMapper .ers Labelled
RMF: Raster Matrix Format
RST: Idrisi Raster A.1
INGR: Intergraph Raster
GSBG: Golden Software Binary Grid (.grd)
GS7BG: Golden Software 7 Binary Grid (.grd)
PDF: Geospatial PDF
MBTiles: MBTiles
MRF: Meta Raster Format
PNM: Portable Pixmap Format (netpbm)
PAux: PCI .aux Labelled
MFF: Vexcel MFF Raster
MFF2: Vexcel MFF2 (HKV) Raster
BT: VTP .bt (Binary Terrain) 1.3 Format
LAN: Erdas .LAN/.GIS
IDA: Image Data and Analysis
GTX: NOAA Vertical Datum .GTX
NTv2: NTv2 Datum Grid Shift
CTable2: CTable2 Datum Grid Shift
KRO: KOLOR Raw
ROI_PAC: ROI_PAC raster
ENVI: ENVI .hdr Labelled
EHdr: ESRI .hdr Labelled
ISCE: ISCE raster
ADRG: ARC Digitized Raster Graphics
SAGA: SAGA GIS Binary Grid (.sdat)
DB2ODBC: IBM DB2 Spatial Database
GPKG: GeoPackage
  1. I'm saving all my data and layers in one folder.

  2. My layers are all in the same coordinate system.

  3. I also tried saving the points I want to interpolate as a shapefile first before clipping

  4. I've been using mask as the clipping mode

  5. I tried saving it as a .tif file and all the other recommended extensions in the error message but it still doesn't want to work.

enter image description here

  • Will you (1) check your GDAL driver using OSGeo4W shell, typing command "gdalinfo --formats" (without quotations) to see if you have GMT (in my case it appears between Terragen and nedCDF); and (2) uncheck OTF (on-the-fly) on your Project properties | CRS, then see what happens if you re-run your clippping? – Kazuhito Oct 31 '16 at 11:45
  • Please ignore my comment (1) above, as probably GMT driver is not related to your issue. Rather, I am more worried about your coordinate system, which shows EPSG:4148 (OTF) on your screen capture. It seems EPSG 4148 is measured in degree unit, Latitude-Longitude basis, so it is less commonly used for gridding or interpolation tasks. As said above (2), I feel uneasy about (OTF), too. Will you double-check your coordinate system, and if possible, try to use projected CRS (X-Y or Easting-Northing)? – Kazuhito Oct 31 '16 at 17:31
  • Thank you very much. I'll try to look into the coordinate system suggestion – Sibu Oct 31 '16 at 20:23
  • The layer I want to clip is a raster layer containing interpolated values so that it covers the Western Cape shapefile/within its outline. I unchecked the (OTF) and tried clipping again however it still doesn't work. The coordinate system I'm using is Hartebeesthoek94 – Sibu Oct 31 '16 at 21:29
  • Thank you for your feedback, Sibu. Then your workflow looks fine to me. Sorry I cannot be of much help. If any projected CRS for Hartebeesthoek94 fits your area, such as TM (LO15~LO33: EPSG 2046~2055), it may worth give it a try. – Kazuhito Oct 31 '16 at 21:54
9

I ran into this same error when running Raster>Extraction>Clipper (QGIS 2.16.0). I just ended up modifying the gdalwarp script at the bottom of the dialog from "-of GMT" to "-of GTIFF" as shown in the screencapture.

enter image description here

  • 1
    Welcome to GIS SE. As a new user, please take the Tour. Please post code solutions as text, in a code block ({}), so they are legible on all platforms. – Vince Dec 29 '16 at 21:11

protected by Community Jun 29 '17 at 17:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.