3

I have faced a weird problem caused by the select-by-location tool of ArcGIS. My goal is to identify the polygons intersecting a reference (colored polygon). Accordingly, I applied the select-by-location tool, but it wrongly included some polygons that there was not any overlap between them and the reference polygon (as the following image).

enter image description here

The interesting thing is that when I use the same function in QGIS, I don't encounter such a problem.

What is going wrong there? Why does the ArcMap fail in correctly determining the intersecting polygons?

  • 1
    If your data are Shapefile format, the Spatial Index might need to be refreshed. – klewis Nov 2 '16 at 18:37
  • Have you tried what @klewis is suggesting? desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/… – BERA Nov 3 '16 at 6:39
  • @klewis, sorry if I answer late; actually, I didn't see your comment in the first place and hadn't access to any computer to test the Spatial Index. Anyway, the Spatial Index solved my problem. Thank you so much. – Federico Nov 11 '16 at 13:15
2

Reasons

  • The tool is set to apply a search distance (uncheck that box)
  • Selected features are multi-part (already ruled out apparently)
  • Not all layers are in the same projection
  • Bad topology (possible but doesn't look like it)

Additionally you could try setting a negative search distance(s) and see what happens.

There is something about your data or tool/environment settings that you are not familiar with.

EDIT - Building off of my last sentence

  • Recalculating the Spatial Index is one option mentioned by others
  • If these layers are Shapefiles you can bring them into a File GDB (thus making them into Feature Classes) and that will generate a new index automatically
  • As mentioned by another, the Repair Geometry Tool might help
  • Make sure there isn't something in your ArcMap session (or .mxd) that is causing this; simply close out all ArcMap sessions and bring the data into a new one

I'm out of ideas at this point.

  • Thank you so much for the reply. I did all the options you mentioned but still face the problem. I cannot surely say that my data have nothing wrong, but, as I said, QGIS doesn't produce such problem when applied to the same data. – Federico Nov 3 '16 at 5:53
  • @Federico -- Edited my answer. If you figure this out please let me know via comments (and you can post your own answer and accept that one if you do indeed figure this out - seems cheesy but it is accepted practice at the SE sites since a good answer to a problem is the real reason the SE exists). – user23715 Nov 3 '16 at 17:32
  • 1
    Thank you for the time you dedicated to my question. I got rid of the problem using the Spatial Index. Thank you. – Federico Nov 11 '16 at 13:17
7

Check to make sure those polygons you're pointing to (the ones that shouldn't have been selected) are not multi-part polygons. If one part of a multi-part feature is intersecting your source (pink) feature, all parts of it (even if others are outside the source feature) will be selected when using Select by Location.

If they are multi-part features, and you don't want them to be, you can split them into individual polygons by editing the layer, selecting those polygons, and using the Explode tool on the Advanced Editing toolbar:

enter image description here

  • Thank you so much for the help. Unfortunately, it didn't work. The polygons were already separated from each other. – Federico Nov 2 '16 at 15:24
2

Try Repair Geometry:

Inspects each feature in a feature class for geometry problems. Upon discovery of a geometry problem, a relevant fix will be applied, and a one-line description will be printed identifying the feature as well as the problem encountered.

  • I am so grateful to you. I employed the Repair Geometry tool and it seemed that it did the trick to some extent (i.e. still some polygons are included wrongly). However, it changed the geometry of the polygons (e.g. all of them got smoothed boundaries, or they were compressed). – Federico Nov 3 '16 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.