2

I'm trying to run QGIS and I am getting constant minidump crashes and "qgis-bin.exe has stopped working" crashes.

I have installed QGIS 2.18.0, the 64-bit version, on a 64-bit Windows 7. The installation went smoothly except for the note that it "Could not find C:/Program Files (x86)/postinstall.log". But when I try to add an ESRI shapefile or raster layer the program crashes with one or the other of these two errors.

This happens in QGIS Desktop both with and without the Grass 7.0.5 add-in. Before installing 2.18.0, I had 2.16 installed for a couple of weeks and the same thing was happening. I uninstalled 2.16 before installing 2.18 the first time. I have uninstalled and reinstalled 2.18 to no avail.

I'm trying to add layers from the local drive, not an external source. I've tried right-clicking, double-clicking, and dragging the layers into the layers panel and into the map area. I've also tried the Add Vector Layer and Add Raster Layer buttons. I've tried adding the sample data included with the download. I've tried unplugging all the plug-ins first. I cannot progress even one step before it crashes.

In contrast, the QGIS Browser module seems to work just fine.

Is this likely to be a problem with the install, or with the way I'm using the program? I'm a newbie with QGIS so maybe I'm just doing something dumb.

closed as off-topic by PolyGeo Jun 3 '17 at 3:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Postinstall log is searched from the 32-bit directory. Could there be some confusion with 32/64 bits? – user30184 Nov 3 '16 at 16:58
  • As your QGIS Browser working fine, it may be related to faulty plugin(s) in your QGIS Desktop. First step is to uninstall external plugins in your Plugin Manager. If it still persists, then try clean install following this post. How to completely uninstall and remove QGIS 2.8.1? – Kazuhito Nov 3 '16 at 17:18
  • 1
    Thank you both for your help. It did turn out to be a 32/64 bit issue. I uninstalled the 64-bit version using the link provided by Kazuhito, and then installed the 32-bit version. Now it seems to be working well. – Artemis Nov 7 '16 at 18:19

Browse other questions tagged or ask your own question.