0

I have a problem with a PostgreSQL table. It is the result of a query that joins 77 tables with 4 columns (geom, inicio, fuente, temporada). I used ST_SRID and ST_Transform because I could not join tables with different SRID.

When I want to export it as shapefile QGIS can not display the file, it does not recognize it. I tried to insert a column ID_0 but the problem continues.

Consulting on this table resulting some sub tables and I could export as a shape, but not others. I do not know if the table is missing some metadata, or did something wrong with the reprojection.

  • is geom column a collection of multiple geometry types? – ziggy Nov 23 '16 at 17:42
  • No, they're all polygons. The problem was that some shapes had values of M and Z and joined those layers with others that hadn't that values. So I removing the M and Z values of some shapes with ArcMap and reprojecting other tables with QGIS to unify the projection of the final table in PostgreSQL, I could finally unite all the tables and export them as a single shape in QGIS. – Carol Gonzalez Jan 26 '17 at 11:40
1
  • Layers With M and Z values alter the final table.
  • ST_Transform did not reproject layers well (for SRID 0).
  • I chose to export layers in a table with the same projection, reproject them with QGIS to SRID 4326 and to rejoin all the layers in the table and with that it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.