2

I have a polygon layer which I want to edit its shape. To do so, I have to edit its nodes.

Polygons

The problem is that some of this nodes are shared by more than a polygon, and when I move the nodes, the two polygons move together.

In some cases this would be great, because it helps keeping boundaries together, but in this case it is not what I want: I want to create a blank space in between.

I've tried some workarounds that worked, but are time-consuming and not elegant at all:

  • Deleting common nodes and creating both polygons again.
  • Adding rings near to the boundaries and then "play" with its nodes to create the space.

Is there an option to avoid the nodes being common to more than one polygon (something maybe like split nodes, or split polygons)?

  • 5
    You have disabled topological editing in snap panel? – pigreco Nov 4 '16 at 11:59
  • 3
    In polygon shapefiles there are no common nodes. Each polygon is an own shape and what looks like common nodes are separate nodes which are at the same position. In your case the editor is configured to move all nodes with same coordinates together. – user30184 Nov 4 '16 at 12:03
  • Shame on me: I didn't remember the "topological editing" option. Thank you @pigreco. (if you want to add that as an answer, I will vote it with pleasure as correct). – Andreu Amoros Nov 4 '16 at 12:05
  • 1
    Agreed, there are no common nodes. If you select polygon first and then the node(s) of this polygon only selected node(s) should move.Make sure that in Settings/ Snaping options... you have turned off topological editing. – Miro Nov 4 '16 at 12:17
5

You have disabled topological editing in snap panel?

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.