7

I have installed QGIS 2.18 Standalone (64 Bit) with SAGA GIS (2.1.2) and GRASS GIS 7. Afterwards I have installed the newest SAGA GIS 3.0.0.

I want to change the SAGA folder in the processing options, but there is no option there anymore (like in older versions and explained in this answer).

enter image description here

Is there another way to change the SAGA path in QGIS 2.18?

EDIT 1:

Is it right that QGIS 2.18 doesn't support the SAGA GIS 3.0.0 version?

In this answer it its explained which Saga Algorithm Provider can be used.

EDIT 2:

I checked the Advanced Options like in the answer from HDunn. There is no SAGA_FOLDER option as well.

enter image description here

  • i see this too (saga works fine from processing, though - bit i'm using saga 2.1.4) Can you run the algorithms from processing successfully, or do get segmentation fault in the logs? also, can you run saga_cmd ok from the command line? – Steven Kay Nov 4 '16 at 18:44
  • The SAGA algorithms work fine from processing. Within the directory C:\Program Files\QGIS 2.18\apps\saga I can run the SAGA (saga_cmd.exe) as well. – Stefan Nov 11 '16 at 11:28
2

In QGIS 2.18.2 on Windows, SAGA folder option came back again. Yay! enter image description here

And SAGA 3.0.0 is now up and running.

enter image description here

2

I doubt that there is much use trying to change the path to SAGA 3.0 since there are no SAGA 3.0 algorithm descriptions in Processing yet:

enter image description here

(screenshot from qgis-dev on 2016-11-04)

SAGA algorithm parameters keep on changing, most likely it's not as simple as renaming an existing folder of descriptions.

1

In the QGIS advanced options -> processing -> configuration menu, you can access the provider paths that used to be in the processing menu, including SAGA enter image description here

  • I tried your advice but there is no option SAGA_FOLDER to change. See my edit above. – Stefan Nov 4 '16 at 15:15
  • @Stefan what QGIS installation do you have? network? standalone? – HDunn Nov 4 '16 at 15:16
  • I installed the standalone version. – Stefan Nov 4 '16 at 15:20
  • @Stefan I've reproduced it, I'll see if there's a solution – HDunn Nov 4 '16 at 16:36
0

I corrected this problem (as far as I can tell) for 2.18.14 by copying the saga folder downloaded via OSGeo [C:\OSGeo4W64\apps\saga] and pasting it into the qgis apps folder C:\Program Files\QGIS 2.18\apps. The folder that this version of standalone Qgis was installed with is saga-ltr. You could try renaming saga-ltr to saga, but I do not know if that will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.