0

I am trying to download the map data (coverage map) from the MAXIS web site. I couldn't find any option to download it directly. This web service has coverage map of two different band widths with Google as base map.

Can we take this URL https://maxisnetwork.tuxgeo.com/v2/) and put it in some applications and download the coverage map data?

MAXIS network coverage map

I have done some research but couldn't find the solution.

1

... and download the coverage map data?

I suppose it depends what you mean by downloading the data, if you mean get at the vector data from which the maps are made then the answer is no.

If on the other hand you mean get at the data as images (the 3G and 4G data are served as individual layers in a GeoWebCache service), then the technical answer is yes.

For example, here's a URL to get at a tile from the 3G coverage layer:

https://maxisnetwork.tuxgeo.com/geoserver/gwc/service/gmaps?SRS=EPSG:900913&layers=maxis:coverage-3g&zoom=9&x=402&y=251&format=image/png8

and here's a URL to get at a tile from the 4G coverage layer:

https://maxisnetwork.tuxgeo.com/geoserver/gwc/service/gmaps?SRS=EPSG:900913&layers=maxis:coverage-4g&zoom=9&x=402&y=251&format=image/png8

For more information on GeoWebCache see the documentation

There is also an associated WMS with service end point of:

http://maxisnetwork.tuxgeo.com/geoserver/maxis/wms?

You can use this WMS service end point to view the service in QGIS

MAXIS WMS in QGIS

  • Thank you very much @nmtoken. Can we use this WMS layer and capture the polygons in QGIS / Mapinfo / any other GIS application or can we create any other openlayer application to capture this? Please suggest. – Bunny Chowdary Mar 9 '17 at 10:20
  • You can use OpenLayers, or QGIS or MapInfo to view the data (as images) from the services, but there is no direct way to capture the actual polygon data. – nmtoken Mar 9 '17 at 10:46
  • I tried connecting WMS to Mapinfo/ QGIS. But I am unable to see the data in map window both in QGIS and MapInfo. I am getting this error HTTP 400. Unable to retrieve the map image from WMS Server. How to achieve this ? – Bunny Chowdary Mar 9 '17 at 11:35
  • what URL did you use? – nmtoken Mar 9 '17 at 11:49
  • here is the URL. once I added this to MIPro / QGIS I am able to choose which layer I want to select as WMS, then I tried with all 3 formats and all 3 available layers I didn't had luck to get them. In QGIS I am able to get the WMS layers into Table of contents but not able to see any content in the map window and in MapInfo i am getting HTTP Error 400. please suggest the necessary steps to achieve this. – Bunny Chowdary Mar 9 '17 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.