1

We have been using r.watershed QGIS-Grass tools for several months now without any problem, even with different QGIS versions.

However, recently the tools are getting us results with a bigger pixel size, even when get the old QGIS version and the same input data that before were working well.

Can anyone help us with this issue?

  • 1
    Do you use Processing or the QGIS-GRASS-plugin. From your question I assume you are using processing. Anyway, can you provide a bit more information on what you are actually doing? – Stefan B. Nov 8 '16 at 7:28
  • We are using QGIS with GRASS. The last version that worked well was 2.10 (PISA) until December 2015. However, – Jose E Villalobos Nov 10 '16 at 18:38
  • We were using QGIS with GRASS 2.10 (PISA) until Dec 2015. However recently, we had to reinstall it. But GRASS ver 6 was changed in the installation packed. GRASS ver 6 was installed separately. Running the r.watershed GRASS tool from QGIS using same ASTER dem (four merged), getting the bigger pixel size in all raster layers results. I think that the problem is, as mentioned bellow, in the region cell size or extent in the plugin actulization. It does not apper in the updated r.watersed or in the region extent window interfaces. – Jose E Villalobos Nov 10 '16 at 19:31
  • Esp. for hydrological analysis I would strongly recommend to move to GRASS 7! The QGIS-GRASS-plugin supports GRASS 7 too. Personally, I would also install a more recent version of QGIS. – Stefan B. Nov 11 '16 at 20:46
1

A little while ago the logic for setting the computational region for GRASS modules was changed in Processing.

If you did not change anything in the "region extent" and region cellsize" options, the pixels of your input and output should be identical (given that you only feed the algorithm with a DEM). Confusion may arise if you feed also e.g. a depression or overland flow map with a different resolution and pixel alignment...

Processing algorithms might benefit from an align option in case of input with multiple resolutions (would require development). But in that case it would be probably better if you adjust maps to each other in advance (using a suitable procedure), instead of leaving that to the software (which e.g. might use NN-interpolation)...

| improve this answer | |
  • Thank you for your answer. We just adjusted the region extend to a smaller one to fix the four ASTER DEMs merged. In this option of the GRASS tool plug in there is not a cell size option. However, I noticed that it does exist in the procesing rutine. – Jose E Villalobos Nov 10 '16 at 19:29
0

OK, if you are using the QGIS-GRASS-plugin you can actually set the region to the input map in each raster module dialogue. See the button on the right hand side of the input raster:

enter image description here

However, I just had a swift look at the region related modules in the GRASS-plugin, and they definitely deserve some love. I will add that to my to do list... So thanks for pointing out the missing functionality...

| improve this answer | |
  • Hi again, One student got a solution. The problem is just the tool that you indicate: set the region with the mouse click and drag. It seems to get the wrong pixel size for the region adjusted. The student just typed the coordinates for the adjusted region directly in the tool box, and then everything works fine related to the pixel size of the resulted raster. Please have a look of that tool and provide us with an answer to have better results. Thanks in advance. – Jose E Villalobos Dec 4 '16 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.