1

I want to extract EVI from Modis MOD13Q1 from some scene of images. I use ModisTool and MRTBatch. I have selected ONLY 250m_16_days_EVI as selected bands. All is correct until I save the parameter file.

The problem is: MRTBatch extract NDVI band, instead of EVI, as I selected.

Anybody knows the problem?

Here is the parameter file:

#The "INPUT_FILENAMES" field would be commented. If you want to load multiple input files please uncomment the "INPUT_FILENAMES" field and comment the"INPUT_FILENAME" field. 
#Also the "ORIG_SPECTRAL_SUBSET" field needs to be uncommented and changed to "SPECTRAL_SUBSET". The initial "SPECTRAL_SUBSET" field should be deleted.


#INPUT_FILENAMES = ( E:\MAP_DATABASE\RASTER\MODIS\MOD13Q1_H30V08_H30V09_H31V09_2010-2014\MOD13Q1.A2010001.h30v08.006.2015198101220.hdf E:\MAP_DATABASE\RASTER\MODIS\MOD13Q1_H30V08_H30V09_H31V09_2010-2014\MOD13Q1.A2010001.h30v09.006.2015198101350.hdf E:\MAP_DATABASE\RASTER\MODIS\MOD13Q1_H30V08_H30V09_H31V09_2010-2014\MOD13Q1.A2010001.h31v08.006.2015198101343.hdf E:\MAP_DATABASE\RASTER\MODIS\MOD13Q1_H30V08_H30V09_H31V09_2010-2014\MOD13Q1.A2010001.h31v09.006.2015198100925.hdf )

INPUT_FILENAME = E:\EVI-batch\TmpMosaic.hdf

SPECTRAL_SUBSET = ( 1 )
#ORIG_SPECTRAL_SUBSET = ( 0 1 0 0 0 0 0 0 0 0 0 0 )

SPATIAL_SUBSET_TYPE = INPUT_LAT_LONG

SPATIAL_SUBSET_UL_CORNER = ( 9.999999999 121.851193415 )
SPATIAL_SUBSET_LR_CORNER = ( -9.999999999 142.159725651 )

OUTPUT_FILENAME = E:\EVI-batch\MOD13Q1.A2010001.h30v08.006.2015198101220.tif

RESAMPLING_TYPE = NEAREST_NEIGHBOR

OUTPUT_PROJECTION_TYPE = GEO

OUTPUT_PROJECTION_PARAMETERS = ( 
 0.0 0.0 0.0
 0.0 0.0 0.0
 0.0 0.0 0.0
 0.0 0.0 0.0
 0.0 0.0 0.0 )

DATUM = WGS84
  • This problem is only exist in batch process for different image scene – Arif K Wijayanto Nov 8 '16 at 9:07
1

How do you mosaic your images? I do believe that it doesn't throw away the other bands. If you keep all the bands from the input HDF-bands, then the problem arises in SPECTRAL_SUBSET = ( 1 ) - where you specify that you want the first band only, while ignoring the rest.
The first band in MOD13Q1 is NDVI, EVI is the second.
To fix that, you should have SPECTRAL_SUBSET = ( 0 1 0 0 0 0 0 0 0 0 0 0 )

Furthermore, please specify if you have added the comments to the parameter file, or if you got it somewhere else.

  • Thank you so much @Mikkel I have fixed this problem by removing the # on the ORIG_SPECTRAL_SUBSET, as follows: SPECTRAL_SUBSET = ( 1 ) ORIG_SPECTRAL_SUBSET = ( 0 1 0 0 0 0 0 0 0 0 0 0 ) And all is well – Arif K Wijayanto Nov 10 '16 at 6:53
  • @ArifKWijayanto don't forget to mark my answer as 'Accepted' by clicking on the tick-mark next to it. This helps to keep the site easier to use. – Mikkel Lydholm Rasmussen Nov 10 '16 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.