0

When I use ArcMap 10.3 and copy records (from attribute table) and paste to Excel I sometimes don't get all of the records pasted. Probably a limitation of cells or rows or something. Of course the alternative is to export data, but copy/paste is a bit faster.

My questions are:

  • Is this a known bug/error in ArcMap, or is it a problem in Excel?
  • Is there anyway to change a parameter or setting or such in ArcMap to get this to work?
  • Within the attribute table, export the results as a DBF file. This can be opened in Excel. All your records from the dataset will be exported correctly using this method. – MacroZED Nov 9 '16 at 16:47
  • Does your last field have null values in it, especially the top row? I found that this almost always caused the first record in Excel to have the next row's data added to it "to the right" and if your table was large enough you wouldn't notice this, but the number of records would be short by at least one. – johns Nov 9 '16 at 17:05
  • What version of excel are you using? – CwecU Nov 9 '16 at 17:37
  • Have you seen the Table to Excel Tool under Conversion Tools? copy/paste is probably easier. – klewis Nov 9 '16 at 18:08
1

I am using excel 2016 and it works perfectly. In older version, there were copy and paste issues for me when I was not in editing mode. Try doing this in editor mode too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.