1

I am trying to follow the tutorial in http://www.qgistutorials.com/en/docs/georeferencing_basics.html to do the image georeferencing. But every time I got strange results.

My image is self created picture, with several known points (I obtain the coordinate of these points from handheld GPS receiver). I'd like to match the image to real world coordinate.

Following the tutorial, I got a geotiff file loaded into QGIS. The problem is that its position is totally wrong. Wrong position is around (0,0) in (lat, lng).

When I open the CSR property of the geotiff file, the coordinate reference system shows Selected CRS, USER100000 (as I'm expecting EPSG3857).

Could anybody help with this?

  • If the coordinates are latlong from GPS, the CRS should be EPSG:4326. Use Set Layer CRS to correct it. Once right, save the file to a different filename for future use. – AndreJ Nov 10 '16 at 6:38
  • @AndreJ Do you mean to set CRS as EPSG4326 to raw jpg image before georeferencing, or to geotiff after georeferencing? – Victoria Zhao Nov 10 '16 at 6:58
  • You should normally do it in the georeferencing settings before running the georeference. Raster -> Projection -> Assign Projection or Set Layer CRS are the tools to correct worng settings. – AndreJ Nov 10 '16 at 11:57
  • I would rather say DURING georeferencing. By Raster | Georeferencer | Georeferencer, you will start georeferencer window. Then the first step will be Open Raster and QGIS will immediately prompt you to Specify CRS for layer Raster. Choose EPSG:4326 as AndreJ commented. – Kazuhito Nov 10 '16 at 12:29
1

I don't know why but seems that I have solved my problem.

First of all I set EPSG:3857 to my raster image when loading (as @Kazuhito said). After that I do the georeferencing, and set target SRS as EPSG:4326.

The generated tif file is loaded on top of openstreetmap, and its position is exactly correct. Thanks everybody for your suggestions!

  • Nice. Thanks for sharing your successful workflow, Victoria. It would also suggest AndreJ's large insight. (I wrongly assumed the original image did not have any pre-defined CRS). – Kazuhito Nov 11 '16 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.