3

I would like to re-calculate large geotiff files (10,000 x 10,000px) with the help of gdal2tiles into little (256 x 256px) tiles. The process works fine. However, the result is not perfect. There is a slight shift in the tiles (see the picture below). I've already tried different resampling methods and get the same result every time.

Here is my statement:

Gdal2tiles.py -s EPSG: 25832 -z 11-20 /home/input/file.tif output_path /

I think there might be a problem with transforming EPSG:25832 to EPSG:3857, but if I try to transform with gdalwarp I get the same problem...

Does anyone have any ideas?

enter image description here

  • do you mean to have a space between EPSG: and 25832, or is that a typo? – Steven Kay Nov 10 '16 at 18:35
2

After days of research I found an answer by myself:

The problem depends on the transformation of the srs from EPSG:25832 to EPSG:3857.

What I did: I created one big .tif with gdalwarp and used the paramter -s_srs EPSG:25832 and -t_srs EPSG:3857 (!important is to create one big file - otherwise there will be a gap between the .tif files). I also had to take the parameter -r cubic . With the default option (-r average) I got the same problem.

So it was really tricky, but worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.