The Python code below looks pretty straightforward.

import arcpy

if arcpy.Exists("D:/temp/test.gdb"):

if arcpy.Exists("in_memory"):


arcpy.CreateFishnet_management("D:/temp/test.gdb/test","0 0","0 1","1","1","1","1","#","NO_LABELS","#","POLYGON")



and when I run it on a PC (ArcGIS 10.0 SP2; Windows XP SP3; 32bit) it completes in 4-5 seconds. This is the case when I run from IDLE or as a Python script tool in ArcMap (where I added it to a toolbox with no parameters).

However, when I move it to a virtual server (ArcGIS 10.0 SP3; Windows Server 2008 R2 Standard; 64bit) it still runs fine from IDLE, but when run as a Python script tool in ArcMap it just sits at:

Executing: test
Start Time: Thu Mar 15 10:31:50 2012
Running script test...

When I move the tool I find a small Error dialog with a white "i" in a blue filled circled.

To dismiss that dialog I click the OK button and/or the "x" at its top right.

When it goes, a second Error dialog appears - this time with the text below:

General function failure [test3]

The Python test code provided here has been stripped out from a much larger tool that I need to publish as a Geoprocessing Service, which in turn requires that I save it as a tool layer within a map at 10.0 (10.1 won't be an option for quite a while).

The culprit seems to be the CopyFeatures from the in_memory workspace which will take some working around, and if I need to eliminate in_memory from this polygon overlay intensive application, then its performance is going to take a big hit.

Would someone be able to run the same test as I describe above on a virtual server (it may also manifest on a physical server but I don't have one to test on) running ArcGIS 10.0 and Windows Server to see if they can reproduce what I am seeing, please?

If it works, or if it does not, can you specify your ArcGIS and Windows versions and whether you ran it on a physical or virtual server, please?


Please accept my apologies if anyone ran or started to try and run this test.

There was an unrelated issue on the virtual server (which I share with many others) that appears to have triggered the error.

Once the virtual server was working properly again the error disappeared.

  • We may be experiencing a similar issue. I don't suppose you remember what the issue was on the virtual server? – Fezter Nov 10 '15 at 6:20
  • @Fezter Unfortunately, I cannot help because I was getting the error one day when I was onsite, and then when I came back a week later they (Qld Govt) just said that the virtual server had been playing up and was all fixed now. – PolyGeo Nov 10 '15 at 6:26
  • That's ok, it was worth a shot. – Fezter Nov 10 '15 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.