2

I am trying to display land cover layer (.tif) into QGIS. But some reason the layer appears in grayscale when I load in QGIS (Figure 1). I am expecting to see the somewhat similar display as in ArcMap (Figure 2). In QGIS, when I looked into the layer's properties, the Singelband gray is a default Band rendering for this layer. I wonder how can I display the layer as in AcrMap or is there steps in QGIS to process the layer to look like in Figure 2.

I'm using QGIS 2.14.3-Essen OS: Windows 8

Figure 1: Looks grayscale in QGIS Figure 1

Layer View

Figure 2: Same layer displayed in ArcMap Figure 2

enter image description here

3

New user without the karma to comment on the above answer — but here's a Github Gist with a QGIS style / .qml file I made based on the above information (it looks like @StuSmith's link no longer works): https://gist.github.com/eidietrich/b069eeead2b542caa7c6d43d3eaf8699

Should be loadable via Layer Properties >> Symbology >> Style >> Load Style.

2

Here's how I enable color:

  1. Drop-down Render Type to "Singleband pseudocolor"
  2. Drop-down Color and select one of the color ramps.
  3. Click the "Classify" button
  4. Click "Apply"

But more importantly, you probably want to match the NLCD colors:

enter image description here

Here's what I did:

  1. Download the NLCD data from: http://www.landfire.gov/bulk/downloadfile.php?TYPE=nlcd2011&FNAME=nlcd_2011_landcover_2011_edition_2014_10_10.zip
  2. Unzip
  3. Add the NLCD .img raster layer into QGIS. Here's what I get, which by default has the correct NLCD symbology: enter image description here

If you would like to save the NLCD style for later use in QGIS, open the NLCD layer properties and click the Style tab. Again, here's what I get: enter image description here

Click the Style dropdown and select "Save Style...". The saved .qml file can be used later on other projects requiring NLCD colors: click the Style dropdown and select "Load Style..", and select the previously saved.qml file. Voila! NLCD colors.

  • 1
    @ Stu Smith,Thanks ! The problem I face with the Singleband pseudocolor is I can't set the unique class code for each land cover classes. Example, I used the "Classify" to symbolize 8 different classes using its class code value but I don't find the option to keep the class unique other than Continuous, Equal interval and Quantile. Another thing, eventually I wanted to see all land cover class label automatically displayed under the Layer Panel instead of its class code. – user59968 Dec 1 '16 at 17:11
  • @StuSmith, I ran into a similar issue as the OP. Do you have any suggestions? Or perhaps even a QML file you can share? I asked a similar question at gis.stackexchange.com/questions/259389/… – RyanDalton Oct 23 '17 at 18:37
  • @Ryandalton I don't know how to attach a .qml file to this thread, so I uploaded ncld.qml to dropbox.com/preview/Public/nlcd.qml?role=personal – Stu Smith Oct 24 '17 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.