4

I have large NJ state wide parcels layer that I dissolved down to 6 records. I now want to dissolve it down too 1 record.

6 record dissolve

my input into dissolve tool

enter image description here

result of dissolve

enter image description here

Why is the dissolve tool not dissolving my layer down to 1 record?

I am contemplating just throwing it into PostGIS and using the st_union function but from my experience that takes forever

3
  • What happens if you turn off "Create multipart features"?
    – Fezter
    Nov 14, 2016 at 22:28
  • @Fezter i get the same output of 6 records
    – ziggy
    Nov 14, 2016 at 23:41
  • Could you please add a screenshot of your six records coloured by OBJECTID? I'm wondering if number of vertices is an issue (unlikely, but it seems to be a common problem). Also, try repairing geometry on your input first.
    – Fezter
    Nov 14, 2016 at 23:50

2 Answers 2

3

I think your answer find in first lines in below text:

Running Dissolve on the output of a previous dissolve run will rarely reduce the number of features in the output when the original processing divided and processed the inputs using adaptive tiling. The maximum size of any output feature is determined by the amount of available memory at run time; therefore, output containing tiles is an indicator that dissolving any further with the available resources would cause an out-of-memory situation or result in a feature that is unusable. Additionally, running the Dissolve tool a second time on output that was created this way may experience very slow performance for little to no gain and may cause an unexpected failure. get more info from enter link description here:

Dissolve- Data Management

1
  • this seems to be the answer for the following reasons 1. the 6 polygons do share a boundary and should have dissolved into 1 record 2. i ran the layer through repair geometry and nothing changed 3. I did a test of only dissolving the parcels that fell within a specific county and it dissolved down to 1 record. 4. adding an integer value or string value and dissolving the layer based on that did nothing
    – ziggy
    Nov 15, 2016 at 23:37
2

The easiest thing to do is to add a field and make all the values the same (such as an Short Integer field and set all values to 1).

Then dissolve based on that field.

5
  • 1
    tried your recommendation but still got the same results
    – ziggy
    Nov 14, 2016 at 20:11
  • conceptually i have no idea why it wont dissolve..
    – ziggy
    Nov 14, 2016 at 20:11
  • @ziggy "Dissolve field" must be string no integer value.
    – Navid
    Nov 15, 2016 at 6:32
  • 1
    @ziggy are the remaining 6 polygons actually overlapping or sharing boundaries? May be they don't touch (e.g. because of rivers marking the boundary)...
    – Hornbydd
    Nov 15, 2016 at 10:37
  • this did not work with a integer value or string value. @Hornbydd they are sharing boundaries I think it is a memory issue as predator X pointed out below. I am currently working on a method in python that will try and break up the processing of the parcels dissolving
    – ziggy
    Nov 15, 2016 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.