0

I downloaded congressional district and county shapefiles from nhgis, i then ran an intersect geoprocess on the two which ended up deleting some of the congressional districts.

This geoprocess overwrote my original shapefiles so I deleted the files and re-downloaded the shapefiles from nghis, but when I opened them up arc the cd file was still missing the districts.

Not sure what is going on here, perhaps a problem with a lock file? I tried renaming the files and looking for a .lock file that I missed somewhere, but no luck. I also tried closing arc and restarting that to see if that would remove the lock but that didnt work either. I am not too familiar with .lock files and have never run into this problem before so I am pretty stumped on where to start looking for answers.

EDIT: im now thinking it is a problem with the original data I am using, could someone confirm this? You can download the data from nhgis, search by geographic levels click all then click Congressional District (1987-1993, 100th-102nd Congress) (by State) and then download it (you do need to have an account). Then see if you are seeing the same thing I am in arc and check the .dbf file to see if is missing arizona (statefp 04) congressional district 01, search 0401.

enter image description here

  • 1
    It sounds like you need to start again and document each step that you perform, starting with the download, so that when you first see something unexpected you will be able to tell us what you want to do, precisely what you tried and where you are stuck. – PolyGeo Nov 16 '16 at 6:08
  • 1
    Note that intersect only retains areas common to both layers so if some Congressional Districts were missing it could be from that process? – jbchurchill Nov 16 '16 at 16:12
  • Intersect should not overwrite original shapefiles – BERA Nov 16 '16 at 19:44
  • i didnt think that was the case either, but as the picture shows above that is the original shapefile, I have tried to delete the file from my machine and redownload it to see if i can get the original file back but it is still the same as the picture above, so I'm not really sure what is going on – captnvitman Nov 16 '16 at 19:47
  • Copy shapefile in a geodatabase. It convert your shapefile to feature class of a geodatabase.Then try to intersect.Be sure that you use Intersect tool correctly. Intersect result never overwrite to the intputs. – BBG_GIS Nov 17 '16 at 5:49
1

Try to reload the arcgis and start as administrator, if you have your shapefile into an external hard drive copy to your machine.

0

So there is a problem with the CD shapefiles for the 90's on the nhgis site where there are just some districts that are moving. Here's the response I received from user support "The missing data in the 101st Congress file stems from the 1992 TIGER/line source data missing attribute information for those areas. Essentially, the original source file failed to identify the Congressional Districts in those areas (for whatever reason), so NHGIS couldn't create polygons for those areas. Those areas could be assigned with a bit of legwork, but we've never had the resources to make it a priority unfortunately."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.