I am having trouble with new shape layers not showing up on my map. When I add the layers they show up fine in the attribute table, but nothing shows up on the map. This happens regardless of what order my layers are in, even when I try to open one in a new blank project I can't see anything.

Additionally, one of the layers I'm trying to use (a shapefile of school districts in a state) displays really implausible coordinates in the status bar. No error message is coming up, or any other type of message that would indicate a problem with the shapefiles.

I am very new to QGIS so I'm pretty out of my depth at the moment.

  • 2
    I suggest to start off with the training material at docs.qgis.org/2.14/en/docs/training_manual
    – AndreJ
    Commented Nov 16, 2016 at 7:43
  • 3
    Have you got all the parts of the shapefile? You need at least three or four files in the same folder: name.shp, name.dbf, name.shx and name.prj to get a shapefile working. Then you open name.shp in QGIS. Are you doing that?
    – Spacedman
    Commented Nov 16, 2016 at 7:59
  • 1
    The first thing that I would check is that you need to specify a CRS for your project and then enabling the on the fly transformation option for the project. Done this, load the shapefiles again and see what happens. Are they now in the correct location?
    – Vale
    Commented Nov 16, 2016 at 8:53

1 Answer 1


Try to zoom to individual layers (right click on layer --> Zoom to Layer). If the layer shows up in map window, you probalby set wrong coordinate system (CRS) for your data, and thus they show up in a wrong place.

You can set the proper CRS when loading layers to QGIS (depends on QGIS settings) or later in layer properties of source layers. If you have data which geometry are in different CRS, set correct CRS for each layer and you can visualise them in required CRS with enabling "on the fly transformation" (Project --> Project Properties --> CRS).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.