0

I've clicked around on a few of the related question. I am not using qgis or anything "fancier" than ArcMap 10.2.2 for desktop and Microstation V8i. Is there a way to successfully convert shapefiles to a dgn file? I've been able to convert and open a shapefile in a dgn, but the coordinate system is always off. Let me know if more information would be helpful!

  • Have you looked at FME? they do a free 30 day trial, and what you asking. – risail Nov 16 '16 at 19:18
  • do you use seed files? – Mapperz Jun 21 '17 at 15:22
1

You can do this in ArcGIS using the Export to CAD tool. The output type parameter has a dgn v8 option:

The CAD platform and file version of the output files. This value overrides any output_type values contained in the keyname column or alias column CADFile_type. Types include DGN_V8, DWG_R14, DWG_R2000

  • I have used this, however the dgn is creates still puts the converted shapefiles in the wrong coordinate system? Whenever I reference in the converted dgn to a pre-existing DGN, the shapefiles are off in space or scaled too big. – Struggling Nov 16 '16 at 17:13
  • 1
    Not sure if this is the cause as I used AutoCAD not MicroStation. In CAD we often worked in model space or on a scaled model. To bring a shapefile as a dxf into CAD we used the align command which was basically a 2 point registration. Another option was take a DXF out of CAD and use spatial adjust to make the shapefile fit the CAD drawing. Then take the adjusted shape to a dxf and back into CAD. This is due to CAD not using real world coordinates and GIS data using it. – Bill Chappell Nov 16 '16 at 17:49
0

Before to load your shapefile convert your dataframe with the coordinate systems that you want to project.

0

Here is a workaround. Go to Microstation, Applications tab and click on Map. This will activate the Bentley Map application. Then go to File->Import->GIS Data Types. In the Interoperability pop-up window, right click on Import and select the first option. A new node should open up under the Import tree. Right click on the new node and select "Add File (the first option)". Then navigate to your shapefile. Set the level and appearance like you want it to be and then right click on the file in the tree and select "Import". This should bring the contents of the shapefile into the Microstation file. It may be slightly off the exact location. IT can be fixed automatically if the correct surface correction factor is know. Or, you can simply manually move it into the correct location. The scale should not be an issue. I have used this option successfully even in cases where the Microstation file is in state plane projection coordinates and the shapefile in GCS American NAD 1983.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.