2

I am using Ubuntu 16.04 and installed QGIS 2.18 following the official install details QGIS Installers using link Release with ubuntugis dependencies http://qgis.org/ubuntugis. I have python 2.7.12 on my system. Every time I start QGIS, the error message is :

Couldn't load SIP module.
Python support will be disabled.
Traceback (most recent call last):
  File "", line 1, in 
ImportError: No module named sip
     Python version:
        2.7.12 (default, Jul  1 2016, 15:12:24) 
        [GCC 5.4.0 20160609]

        QGIS version:
        2.18.0 'Las Palmas', b7fe4bb2

        Python path:
        ['/usr/share/qgis/python', u'/home/user/.qgis2/python', u'/home/user/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/local/lib/python2.7', '/usr/local/lib/python2.7/plat-x86_64-linux-gnu', '/usr/local/lib/python2.7/lib-tk', '/usr/local/lib/python2.7/lib-old', '/usr/local/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/site-packages']

on the python IDLE i can to import SIP module. any idea how to fix that ?

UPDATE

if i run cat /etc/apt/sources.list

show me (only related to QGIS):

.
.
.
deb http://qgis.org/ubuntugis xenial main
deb-src http://qgis.org/ubuntugis xenial main

update i have python 2.7.12 and sip version 4.17,qt version 4.8.7,pyqt version 4.11.4 after reinstall qgis now i have that error:

Couldn't load SIP module.
Python support will be disabled.
Traceback (most recent call last):
  File "", line 1, in 
ImportError: /usr/local/lib/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_AsUTF8String
Python version:
2.7.12 (default, Jul  1 2016, 15:12:24) 
[GCC 5.4.0 20160609]
QGIS version:
2.18.0 'Las Palmas', b7fe4bb2
Python path:
['/usr/share/qgis/python', u'/home/user/.qgis2/python', u'/home/user/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/local/lib/python2.7', '/usr/local/lib/python2.7/plat-x86_64-linux-gnu', '/usr/local/lib/python2.7/lib-tk', '/usr/local/lib/python2.7/lib-old', '/usr/local/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/site-packages']

('Qt version:', '4.8.7') 
('SIP version:', '4.17') 
('PyQt version:', '4.11.4') 
  • Please only ask one question per post. – Mattropolis Nov 16 '16 at 19:35
  • ok i update sorry – Mar Nov 16 '16 at 20:12
  • Can you edit your question to put the result of this command: cat /etc/apt/sources.list (only the QGIS corresponding part). – xunilk Nov 16 '16 at 20:41
  • update with result to ask me – Mar Nov 16 '16 at 21:51
  • Try out this repository: http://qgis.org/debian. It is recommended first (related to Debian/Ubuntu) in this link: qgis.org/es/site/forusers/alldownloads.html#debian-ubuntu. I load sip module at the Python Console of my QGIS 2.18 (Debian system) without problems. – xunilk Nov 16 '16 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.