I have installed QGIS on Mac, using Homebrew:

  brew install qgis2 --with-r

from osgeo/osgeo4mac. I did not want Grass ( although I have laso tried --with-grass . In the processing toolbox, I went to activate the rscripts. So far so goo, but when hitting ok, QGIS complains that the path to Grass 6.4 is not found ( not sure why it does that). I cannot activate my R. ANy hints how to go about this? There is no option to delete the grass integration, and despite not activating grass, this complains.


In Processing options (alt+ cmd+ c), in GRASS GIS 7 commands deselect Activate button and delete path in GRASS7 folder slot. Do the same with GRASS commands.

I did it to work with R and works. But if this not work for you, install GRASS disabling SIP and change path.


  • I have followed the instructions. Failed 3x, the fourth time it worked. Non-deterministic behaviour, but it worked at last. I would add some kudos if someone told me how to set the path properly if installed --with-grass (do I need to isntall grass separately too?) – MartinT Nov 20 '16 at 23:33
  • You need to have GRASS GIS installed, yes. And its startup script needs to be in the PATH. – markusN Nov 27 '16 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.