2

On a geonode 2.4 installations I have hundreds of layers. When creating a new map (as logged in admin) I can see none of them in the available layer tree. It just stays empty. geonode.log does not show any error.

I recognized that the Geoserver which is running on same machine is not in the list.

Thus, I tried to add it like http://mygeonode.org/wms/ unfortunately this does not work.

This is how my server definition on local settings looks like:

    GEOSERVER_URL = SITEURL + 'geoserver/'

# OGC (WMS/WFS/WCS) Server Settings
OGC_SERVER = {
    'default' : {
        'BACKEND' : 'geonode.geoserver',
        'LOCATION' : 'http://localhost:8080/geoserver/',
        'PUBLIC_LOCATION' : GEOSERVER_URL,
        'USER' : 'admin',
        'PASSWORD' : 'geoserver',#'password',
        'MAPFISH_PRINT_ENABLED' : True,
        'PRINT_NG_ENABLED' : True,
        'GEONODE_SECURITY_ENABLED' :True,
        'GEOGIG_ENABLED' : False,
        'WMST_ENABLED' : False,
        'BACKEND_WRITE_ENABLED': True,
        'WPS_ENABLED' : True,
        'LOG_FILE':'/usr/share/geoserver/data/logs/geoserver.log',
        # Set to name of database in DATABASES dictionary to enable
        'DATASTORE': 'datastore',
    }

What´s wrong with my local geoserver configuration?

enter image description here

1

If your siteurl is set to be http://mygeonode.org, you will also need to add that to allow host form the local_settings.py.

Restart apache2 server and also, if ubuntu, from the terminal run this $ sudo geonode updatelayers

That shall fix it.

  • Hi Elai_GEOINT, thanks for your reply. I forgot about that thread but should have closed it. In the end the reason were some "Zombie Layers" in GWC. – t Book Jul 14 '17 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.