2

I am working with world soil drainage data from the Harmonized World Soil Database v 1.2. The data started as an ascii file with no spatial reference and a resolution of 0.080595956, 0.080595956 Arc seconds, I later converted it to a raster file for ease of use.

After converting it to a raster I then defined the projection of the data into WGS_1984_World_Mercator as the data encompassed the world and I figured that's probably what the data was originally projected on (the original projection was not in the meta data).

The data projected fine then I proceeded clip the data to the study area and then reproject the data into WGS_1984_UTM_Zone_37S as this was the study area. The data reprojected but appeared on a different layer then the rest of my working data that is projected into WGS_1984_UTM_Zone_37S.

When I checked the source data the projection changed but the cell size appears to still be in Arc seconds:enter image description here

enter image description here

I want the cell size units to be in meters. So far I have tried reprojecting and defining the data to make sure it wasn't an arc map error.

I also tried to reset the display units and the coordinates system from the data frame properties window. If you have any idea of what is causing this problem or have a solution let me know.

  • This is kind of a weak suggestion, but maybe export or raster.save( ) between the projection and the clip and maybe let it save to the default gdb. That's sort of the equivalent of "tunk it a little." Also maybe project to UTM before the clip. – J Kelly Nov 21 '16 at 13:47
  • 1
    Website of the dataset says 30 arc-seconds, not 0.08 arc-seconds. I think the data is in decimal degrees and you should assign it WGS84 (EPSG:4326). Clip out the area you're interested in, then use the Project Raster tool to create a raster that's in a projected coordinate reference system, like a UTM zone. – mkennedy Nov 21 '16 at 20:53
  • Thanks for looking into it! I must've overlooked it when I was gathering the data. I will let you know if it works. – ddffit Nov 21 '16 at 23:45
  • That did the trick! Thanks for the help. I really biffed it by first projecting it into the wrong projection and failing to thoroughly check the metadata. – ddffit Nov 21 '16 at 23:59
1

Have you tried using the Image Analysis Window?

Top menu bar - Windows - Image Analysis.

Start a new data frame, and ensure the projection is set to the one you want for your workspace. Add the datasets you wish to use and then reproject the raster in question.

Once you have re-projected your raster, use the Image Analysis window to clip out the area of interest. You can save/export your raster from here. Make sure when you export to check the datum/ resolution/ data type/ etc.

The Image Analysis Window is very powerful - It will process everything as a temp file, so if you close ArcMap you will lose any outputs/functions that were not exported. So if you work in the IA Window, make sure to export your final outputs before saving and closing your MXD.

Here's a link for more info on the IA Window.

http://desktop.arcgis.com/en/arcmap/10.3/manage-data/raster-and-images/image-analysis-window-processing-section.htm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.