I've a polygon layer on PostGIS, and when I try to add featureS using QGIS it gets error when I save the edit.

Here is the error notification "no result buffer".

Here, the error picture

I found a similar case here : PostGIS error while adding feature: no result buffer. But it doesn't give me the answer to solve it. Any ideas ?

  • Does anyone have a way to solve this issue without restarting? I don't want to lose the work I've done, so restarting is a problem.
    – Alicia
    Commented Mar 26, 2019 at 18:05
  • @Alicia What worked for me was opening the affected layer's Properties dialog then selecting OK. After doing this the save worked fine. There may be other factors at play (i.e. I restarted the DB beforehand though to no effect). If I can reproduce this I'll post a proper answer. (My reasoning behind opening the Properties dialog was to coax QGIS into refreshing its DB metadata). I'm using QGIS 2.6.0. Commented May 27, 2019 at 9:49

1 Answer 1


I have had a similar error. From the QGIS PostGIS log:

Unable to access the "gvkort"."modelomr" relation.
            The error message from the database was:
            no result buffer.
            SQL: SELECT * FROM "gvkort"."modelomr" LIMIT 1

I suspect this was due to a database timeout after a long meeting not using QGIS with an open pg connection. After restarting QGIS the problem went away - and not before. This happens a lot in pgadmin, but have never seen it in QGIS before.

  • 2
    I had the same error, so following this advice I closed the QGIS project down and opened it up again, and this time it worked, no error. Thanks Commented Aug 7, 2017 at 18:29
  • I have the same problem. QGIS 2.8.15, PostGIS 2.4.2. I tried to log it in PostgreSQL with the highest level of registered events. The only message that refer to the error, when I click "Save" button in QGIS, is Connection error: SELECT nextval('myschema.mytable_id_seq'::regclass) returned 1 [FATAL: terminating connection due to administrator command]
    – Yaroslav
    Commented Jan 22, 2018 at 8:22
  • this error still persisting and it's almost 2020
    – Luffydude
    Commented Oct 9, 2019 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.