I'm trying to use QuickOSM to find some items within the extents of a polygon layer, but every time I run a query with the "extent of a layer" radio box checked, QGIS immediately closes. This happened with every layer I tried, in several different coordinate systems. (Using the map canvas extents worked the way I expected it to.)

I did a little searching, but the closest I came to my problem was this bug report, which was resolved in 2014.

Is there still a problem with layer extents in QuickOSM, or if not, can anyone tell me what I'm doing wrong? Am I using older, or incompatible, versions of QGIS or QuickOSM?

(The versions I'm using are QGIS 2.18.0 on Linux Mint 17.3, and QuickOSM plugin version is 1.4.5.)

  • Same crash here. It seems that extent of a layer is not implemented as expected. You should re-report the issue on Github.
    – AndreJ
    Commented Nov 27, 2016 at 6:43
  • I opened a new issue on their GitHub site, we'll see what they say.
    – Don
    Commented Nov 28, 2016 at 14:20
  • A strange development: I was having trouble using pyuic4 (different project), and eventually commented out the lines for sip.setapi() in QTCore.py. After doing that the QuickOSM plugin would run the query with extents from a layer, but "generate query" still crashes.
    – Don
    Commented Dec 10, 2016 at 17:42
  • I just tested with QGIS 2.18.1 on Windows and Linux Mint, and it works as expected.
    – AndreJ
    Commented Dec 10, 2016 at 18:17
  • I upgraded to 2.18.1 recently as well @AndreJ, maybe that (rather than messing with setapi) was what made the difference for me as well.
    – Don
    Commented Dec 10, 2016 at 19:35

1 Answer 1


This was a bug in QuickOSM. Thanks for the bug report https://github.com/3liz/QuickOSM/issues/88 This has been fixed in the plugin. You should update your plugin in QGIS.

  • Just upgraded and tried it -- everything works as expected. Thanks!
    – Don
    Commented Apr 5, 2017 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.